Problem installation Wordpress

Hello everybody,

I am new and I am trying this great CP, I was looking for a very light and slim one for some website works on fiverr

I’m sorry that I start with a problem. A problem installing wordpress on a new test domain results in this error in screen: Screenshot by Lightshot

I tried to delete the contents of the domain several times, but this error comes up every time. What did I do wrong? Thanks a lot!!

When you create a domain index.php or html (can not remember) and another file is written in the domains root directory, delete the files and the error should go away.

I just verified on my server.
Created domain
When to /home/[USER]/web/[DOMAIN]/public_html
Deleted the Index.html and robot.txt
Quick Apps > Wordpress

Installed without a hitch.

If problem persists I would delete the domain and recreate it then do as I did above.

Thanks Liam,

the error persists. Even changing the domain several times.

Delete the webdomain, recreate it, without doing any other changes go to quick installer and run it - should work out of the box.

Keep giving me that mistake.

I don’t think it’s IP pointing problem. I have servers on digital ocean.

the test domain points to the ip correctly. Should you need this information, ScIT…

Thanks a lot!

Please tell us all the actions that you have taken, step-by-step. Like:

  1. Login to Hestia with admin
  2. Login user X
  3. Click on Web tab
  4. Click on the delete button on domain zzz.com
  5. Got message "Are you sure you want to delete… " and clicked OK
  6. Etc… Etc until you see this error

Describing in detail what you do is vital for the rest of the community to be able to help.

2 Likes

Hello Felix,

  1. ip_hostname:8083 in chrome tab

  2. insert username, password and login

  3. WEB–>add web domain

  4. insert domain and select ip address server—>Save

  5. WEB–>Edit Web domain–>Quick install app–>Setup Worpress

  6. insert wordpress account email and password. Then, flag “database Create”–>Install

  7. Data loss warning!
    Your web domain already has files uploaded, the installer will overwrite your files and/or the installation might fail.

Please use the installer only for empty web domains

Perfect! Now, please:

  1. delete that domain
  2. use the file manage or ssh to your server and check if the directory /home/[user]/web/[domain.com] exists
  3. if it exists, delete the directory [domain.com] in /home/[user]/web/
  4. repeat steps 3-6 you described in your previous message
3 Likes

Hi Felix, thanks for your help!

Following the procedure continues to give me:

Data loss warning!
Your web domain already has files uploaded, the installer will overwrite your files and / or the installation might fail.

Please use the installer only for empty web domains

Since you are not posting step-by-step details of what you did and just jump to the result, I assume that you carried out step 2-3 of my instructions above (but you didn’t make it clear if the directory existed or not). If my assumption is correct then I guess this is a dead end and I don’t have anything else to suggest.

the directory was not there. I followed your steps: 1 - 2 - 3 - 4

HI @Chris92 , if is like you say (directory not there), this is the solution as @Felix says

this is a dead end and I don’t have anything else to suggest.

Beside this, just to understand, how are you checking the folders? by FTP? By SSH? Di you try to delete from the folder as root ?

Hi Ubi,

I check the folders from the hestia control panel. Also from here I deleted the folders and files.

I do a test by implementing everything via ssh. Thanks a lot!

I’ll let you know…

@ScIT @Felix @Ubi @liamgibbins

Sorry guys, I’ll tag you all. I solved the problem!! I wanted to let you know

here’s what the problem was:

I realized that I have the proxy-nginx disabled from the hestia panel. I checked on the server with SSH logins and in fact there was a problem with nginx, screen: Screenshot by Lightshot

i ran the command: nginx -t and here is the result: Screenshot by Lightshot

I went on that path, and here’s how it turned out: Screenshot by Lightshot

I went to the test user I created on hestia, deleted the domain and reinstalled as per procedure. And now I have successfully installed wordpress on hestia with no problems encountered so far. the domain I am testing with is t2.digital-turtle.dev

At the moment I BELIEVE there are no problems. I hope it will be of help to someone in the future. Thank you all!

2 Likes

Don’t disable the “proxy” if you don’t want to use nginx “proxy” feature create an template that doesn’t cache. This function that should never been implemented imo will be removed from Hestia GUI in 1.4

It doesn’t make sense as Lets Encrypt will break and a few other things.

1 Like

Thanks for the explanation eris,

In fact, I don’t remember having disabled it. I am sincere! These I am doing are all tests to know the control panel, so I did a full install of hestia.

In a fresh install I will put the nginx web server without proxy. If I have problems I will look here in the forum :v:

Thanks again

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.