Problem with emails and roundcube


I have a small VPS where I set HestiaCP using a tutorial, added my domain in it, I set hostname and so on. After that proces I added an account with my domain name and installed a website on it. It worked all good, I also added more websites without domain and all worked well.

Now I added a new account and I connected the domain to server hostname, but it is not working properly at all. After a few hours of trying to fix that without success, I decided to go with cloudflare nameservers and after that I put my DNS records with DNS Only settings. After all, my website is working well, but I cannot access mails using webmail. domain. com or domain. com /roundcube, and neither using software like Thunderbird or Gmail on mobile phone.

When I try to open webmail. domain. com - It opens root domain (domain. com) and show website.

I tried a few different tutorials from this forum and around the web, but with no success. I will appreciate it if someone can help me to find a solution.

Here are my screenshots from the current setup!



Remove and webmail.domain.con from the Alias list

Problem is still there. After write webmail . domain . com it redirects to domain . com. Instead of Roundcube everytime opens homepage of website.

It seems to work now. Thank you. At first problem are my browsers. Somehow they did not load roundcube from my vps because we use it on old hosting before. I totally forget to clean my browser history and cache.