Problem with mail

As the title says. I can’t anywhere where to fix this in Hestia panel or Roundcube.

  1. I have been having issues with my mail going into everyone’s spam folder. I have SPF/DMARC set in DNS.
  2. Can’t switch to TLS IMAP 993 and SMTP 465, it reverts back to IMAP 143 etc.
  3. I need to turn on auto reject for all incoming mail for one of my emails.

sorry to say, but this is usually nothing Hestia can help you with.

Mail reputation depends for a big part on the IP/network your provider/DC handed over to you and what reputation that has. DNS settings are also a big part, but there are enough tools to check that this is fine.
apart from that obivously also the content of your mails, the frequency and about a million other things come to mind for what your success of delivering to the inbox directly depends on.

Hestia is a simple control panel for setting up initial configs, no mail tuning included :wink:

I don’t understand your problem regarding the ports though. did you enable ssl on your mail-domain?

for automatically rejecting mail this is also something Hestia does not offer as a feature, so you need to check options how to do that in Exim for yourself.

no offense meant, but we can’t offer support for things like that for free, we simply try to focus on fixing issues or bugs with Hestia :wink:

1 Like

Check Struggling to send anything from Exim4 first


But the issue with the ports is on Hesita’s side. My domain is SSL enabled, but when I switch it in the control panel under Mail settings it reverts back to unsecure port 143 for IMAP.

I am afraid I can’t follow. what mail settings in which control panel are you talking about where you want to switch to 993? I don’t think Hestia has a switch like that.

dovecot per default is listening on ports 143 and 993 for imap (see e.g. netstat) and you can check from another box with f.i. openssl if the cert is correctly delivered on 993 and if the handshake is happening properly.

so if you are talking about whatever mail client you are using maybe it tries to connect with the wrong method or doesn’t support TLS properly? or your ssl cert is not deployed correctly? again something to verify with a simple openssl connect from another box :wink:

This only modifies the credtials below all the options are still enabled :slight_smile:

1 Like

@eris said, this whole block is just like a template to copy and give to clients afterwards. it does not change any settings itself, because all of the options are available anyway.