Problem with phpmyadmin and with a forum

Hi.

Please help me out.
Can find the url for phpmyadmin
ipvps/phpmyadmin - doesn’t work

And also please tell me what’s the preblem it may be…
I remember I have this problem on vps without hestia or any other panels and it needed

sudo chown -R www-data:www-data /var/www/vanilla

So I really think it may be cause of permissions or group…but I can’t decide it
Link

Check if your user is owning those folders

stat /home/user/web/flarum.pp.ua/public_html/cache
stat /home/user/web/flarum.pp.ua/public_html/cache/twig

Don’t chown www-data as your files are executed trough php-fpm with your user

1 Like

Use your domain name, not ip. IP doesnt serve anything due to security reasons.

I didn’t do that, first I post here for you advice.
ffz
Showing the picture…
I restart also php-fpm and after creating the folder nothing good happened

I use Cloudflare and my VPS ip is hidden, so for me it’s better to open phpmyadmin from ipvps/phpmyadmin that giving the opportunity to someone go to mysite/phpmyadmin/ and try their luck. Please if it’s possible give me 2 ways/solutions on how:

  1. to use phpmyadmin from ipvps/phpmyadmin
  2. to change the directory of phpmyadmin if to use it on domain
    mysite.com/bbb/ would be better than mysite.com/phpmyadmin

Thank you!

check v-change-sys-pma command.

why not just use it from hostname like it should be used? It is web and should be used anyway over ssl, so just open it from a secured domain and you’re good to go (https://hostname.domain.tld/phpmyadmin).

that’s the problem, your files are owned by root.

2 Likes

… and at all: Not a problem of or caused by hestia :slight_smile:.

Thanks! Yes because I installed it from the command line. IDK how to install it from the Hestia. It seems like there’s no file manager on Hestia. At least I didn’t find it.

Please give me the command to make it owned by Hestia

fzz

I’m sorry, but I think we need to draw a line here: The idea behind the forum is to help out with hestia related issues and questions. In your case, and I don’t mean this in any case offensive, there is a big lack of knowledge how to handle linux systems including their right management.

I would suggest if you could have a look at a (reseller) webhosting, which would probaly fit better with your requirements.

I asked only a line. That’s it. And it think it’s kinda related to the hestia, because when it’s installed, my forum isn’t woking. Okay I’ll wait monsieur Lupu. Thanks for you time.

I use VPS because I have a lot onf things on it, not only sites. Rocket.chat, nextcloud, vpn, socks, dns.

Of course I can answer you this line: https://linux.die.net/man/1/chown

But just to repeat: Wrong permission set isnt in any case a hestia issue…

@danonanon
The easiest way to open PHPMyAdmin would be using your direct IP/phpmyadmin or whatever you changed your URL with PMA command ScIT quoted above.
If IP/phpmyadmin doesn’t work and if you are behind Cloudflare, just create an entry in your hosts file like
1xx.2xx.xxx.xxx ServerName
and then open in your browser ServerName/phpmyadmin
This will bypass cloudflare’s lookup and take you straight to PHPmyAdmin.

I think you fiddled up way beyond needed, you did not needed to have PMA install of your own as Hestia already installs it for you globally server wide. Better start with a clean install if possible or else go step by step about permissions as advised above

1 Like

I asked only about a line…not about the whole guide…

chown -R www-data:www-data /var/www/vanilla

As far as I understood Lupu, I need to change that www-data:www-data
What hestia created? I found hestia-users in /etc/group and tried
[email protected]:~# chown -R hestia-users:hestia-users /var/www/vanilla
chown: invalid user: ‘hestia-users:hestia-users’

I’m really tired of finding the solution. Spend almost 2 days for it. Why not just to give me the nice solution, the line? I’m not a pro like you and it’s harder for me to find the solution.

If your hestia had file manager I would not ask this question and would not face this problem and my forum would work well because it was created from file manager, not the command line with different ownership.

Thanks for the solution! It works!

Wrong User, probaly wrong position. I think you’re in /home/USER/web/DOMAIN/public_html. So according it should be something like chown -R USER:USER /home/USER/web/DOMAIN/public_html.

Because, as I described above, this problem is not related to hestia - it is a user sided issue due to a lack of knowledge.

Please be sure what you are doing here: You running a whole webserver in the wild (aka internet) - you have to maintain the server, install updates, be able to read/understand the logs and much more points. If you don’t know how to handle it, your server is a risk and can probaly get hackend - so we have a server more that is part of a botnet or spamming around…

2 Likes

Yeah my bad. I was so dissapointed that tried wrong location :slight_smile:
chown -R user:user /home/user/web/mysite/public_html
This helped me. Thans for you time once again I’m happy now.

Here you sound like maintainin a vps is so hard like sending rockets into space. It’s not like that. But yeah sometimes I spend 2-3 days to find a solution which is so easy…
My server has been audited a few months ago, so it’s ok, no botnets and ip isn’t in blacklist for spamming cause there’s no spamming.

Once again thanks for the help. Now I’m totally happy :+1:t2: