Problems configuring remote backup with B2 protocol (Backblaze)

Hi friends,
I have problems configuring remote backup with B2 protocol (Backblaze) in Hestiacp updated with realease 1.5.7.
I have created OK a bucket in Backblaze with its Application ID (KeyID) and Application Key (applicationKey).
But remote backups are not performed.

This is the error in /usr/local/hestia/log/backup.log :

ERROR: Missing account data: ‘NoneType’ object is not subscriptable Use: b2 authorize-account or provide auth data with “B2_APPLICATION_KEY_ID” and “B2_APPLICATION_KEY” environment variables

Can you help me to solve this?

I had a similar problem, does your applicationKey have any weird characters. So like dashes, periods, equal signs, etc… If it does try to regenerate it until its just alphanumeric(easiest way). I was too lazy to try to escape them but in theory you could probably do that as well.


Yes, indeed it has strange characters.
You will try his suggestion.


Finally it worked OK after regenerating several times the application key

Thanks a lot :muscle:

How did the application key looked like?

Containing an #?

No. Initially it had characters like ‘+’ and “\”.

Then I did what “zedpro” suggested: regenerate a couple of times until the generated key had only normal alphanumeric characters.
Then I directly edited the file b2.backup.conf and run v-backup-users to perform a full backup and everything worked OK.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.