Problems with Lets Encrypt certificate

Hestia Control Panel:
v1.5.0 Operating System:
Debian 10.11 (x86_64)

The certificate was generated by the hestiacp panel, it did not indicate any error in the process.

When accessing the site, it presents an SSL certificate error

image

Checking the certificate through the website SSL Checker

I don’t understand why I can’t access the site with SSL

SSL has expired for over 150 days

renew with:

v-add-letsencrypt-domain user domain.com alias.domain.com or via web ui

v-add-letsencrypt-domain mvix melatoninavix.com www.melatoninavix.com

Error: Let’s Encrypt new auth status 429 (melatoninavix.com)

https://forum.hestiacp.com/search?q=429
https://docs.hestiacp.com/admin_docs/web/ssl_certificates.html#error-let-s-encrypt-validation-status-400

Perfect, I saw the log minutes after posting to the forum

{
“type”: “urn:ietf:params:acme:error:rateLimited”,
“detail”: “Error creating new order :: too many certificates (5) already issued for this exact set of domains in the last 168 hours: melatoninavix.com,www.melatoninavix.com: see Rate Limits - Let's Encrypt”,
“status”: 429
}

I have another domain that shows when renewing the certificate.

v-add-letsencrypt-domain clin clinassessoria.com www.clinassessoria.com
Error: nginx restart failed

Then you need to verify, why your nginx isnt starting properly :slight_smile:. Will be probaly the source of your renew issue.

I’m trying support for just that, figuring out the problem.

The nginx service is running on the hestiacp panel

v-restart-web
Error: nginx restart failed

log in /var/log/hestia/error.log
2021-11-26 08:50:19 v-restart-web [Error 20]

nginx -t will give you more informations.

We run a config check before restarting

nginx -t
bash: nginx: command not found

sorry i didn’t understand about the check before reboot

systemctl restart nginx

and then

systemctl status nginx

systemctl restart nginx
no errors

systemctl status nginx
active (running)
no errors

systemctl status nginx

● nginx.service - nginx - high performance web server
Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2021-11-26 09:27:21 -03; 8s ago
Docs: nginx documentation
Process: 9880 ExecStart=/usr/sbin/nginx -c /etc/nginx/nginx.conf (code=exited, status=0/SUCCESS)
Main PID: 9883 (nginx)
Tasks: 7 (limit: 4915)
Memory: 5.3M
CGroup: /system.slice/nginx.service
├─9883 nginx: master process /usr/sbin/nginx -c /etc/nginx/nginx.conf
├─9884 nginx: worker process
├─9885 nginx: worker process
├─9886 nginx: worker process
├─9887 nginx: worker process
├─9888 nginx: cache manager process
└─9889 nginx: cache loader process

Nov 26 09:27:21 xstocler.ddns.net systemd[1]: Starting nginx - high performance web server…
Nov 26 09:27:21 xstocler.ddns.net systemd[1]: Started nginx - high performance web server.

v-restart-web
Error: nginx restart failed
2021-11-26 09:28:58 v-restart-web [Error 20]

What happen when your run:

which nginx

[email protected]:/# which nginx
[email protected]:/#

It would not explain why the nginx command is not working

Does the file /usr/sbin/nginx exists?

There is the file in the folder

[email protected]:/usr/sbin# ls -l nginx
-rwxr-xr-x 1 root root 1370296 Nov 2 12:01 nginx

Could someone help me with this problem?

My knowledge is very limited but I can suggest two things.

Take another hestia install. Point DNS and get the LE certificate. Then copy the certificate in this hestia install and point DNS back.

This would at least solve your problem for now.

Have you tried buying an SSL certificate?

thank you for the reply.

My biggest problem would be the v-restart-web command
Where there is error 20 in the log

v-restart-web
Error: nginx restart failed

2021-11-26 13:53:42 v-restart-web [Error 20]