Problems with the webmail domain page

Hello, sorry for my bad English, it is not my first language.
I have problems with hestiacp, specifically I try to enter the “webmail” website after installing the mail server but every time I try to enter I get the “ERR_CONNECTION_TIMED_OUT” message.
All my DNS Records are well configured in Namecheap just as they are in Hestia (note: I am using Namecheap’s nameserver, maybe that is part of my problem, should I use cloudflare?).

When I go to the webmail error log, nothing appears. It is empty.

On the surface, all services seem to be working well.

Can anyone here think of the possible causes of this problem?
Maybe I should add a DNS record?
If you want any log, tell me which one and I will deliver it.

Hi @sylar,

Yes, seems your server is in a home lab, I suppose Jazztel’s router is blocking the connection to your internal server.

$ nmap -T4 -Pn -v -p-
53/tcp   open  domain
554/tcp  open  rtsp
8083/tcp open  us-srv
10011/tcp closed unknown
50805/tcp closed unknown

The only open ports are 53, 554 and 8083 but neither 80 nor 443 are open. Did you configure port forwarding correctly?

1 Like

Well, in NAT/PAT I have them like this:

Should I have done it differently? (Note: “both” means tcp and udp at the same time)

That looks good but I’m wondering where is 554 port coming from.

In your server, if you are using Ubuntu, check whether ufw is disabled.

sudo ufw status

If it is enabled, disable it.

sudo ufw disable
1 Like

The 554 comes from an rtsp camera. Which curiously is on a different virtual machine with another IP.
And the command with ufw has not returned anything.

Show the output of:

sudo iptables -S
1 Like

Some ISPs block ports 80 and 443 (they use those ports to manage the router), you can test whether this is the case, redirect external port 444 to your internal port 443 and external port 81 to internal port 80 and try to access using those ports, if it works, then Jazztel is blocking those ports and you should talk to them just in case they can change the management ports to another ones (it is possible that this request will be denied).

1 Like

In the end I found out what was wrong. After Sahsanu’s comment I started to think that this was a configuration problem with my router and the NAT/PAT. In the screenshots I uploaded earlier these were cropped: I actually had more NAT/PAT rules from my past experiments with virtual machines. Many of those rules used port 80 and 443. I removed those rules and now I can access webmail.
I have learned now that there are problems if multiple applications or virtual machines use the same ports…
Thank you very much Sahsanu for his help.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.