Quick Install App: Can't install anything

Hello.

A few days ago, I tried to use Quick Install App (QIA?) and install Wordpress.
It fail and I did a manuall install. No time to see or test.

Today, I’m trying to install Laravel on a domain not registered yet.
It’s used just for dev and forced on my /etc/hosts

I got a “Error downloading composer” message, and I can’t install Laravel.

How can I debug this?

I check /var/log/hestia/{error,system} and seems that there is nothing related.

Hestia Control Panel: v1.1.1
Operating System: Ubuntu 18.04 (x86_64)

Just a quick thought: Is DNS resolution working OK on the VPS? Maybe it can not resolve the address of the download server?

As far I know, DNS resolution is working OK.

Every test that I do, there is no error (10 random test with dig, another 10 random with hosts)

apt-get and etc are working.

I did a firewall clean up, too.

‘Error downloading composer’ is thrown when this command fails:
wget https://getcomposer.org/installer --quiet -O /tmp/hestia-webapp/composer-setup-XXXX.php

I have tested a clean install of v1.1.1(ngx+a2+fpm) on ub18.04 and could not reproduce this issue (with real or fake domain)

Steps to reproduce from clean install are needed.

1 Like

wget and curl seems to be ok when I tried to download from getcomposer.org

[email protected]:~# wget https://getcomposer.org/installer -O /tmp/composer-setup-XXXX.php
--2020-04-27 19:03:14--  https://getcomposer.org/installer
Resolving getcomposer.org (getcomposer.org)... 142.44.245.229, 2607:5300:201:2100::4:d105
Connecting to getcomposer.org (getcomposer.org)|142.44.245.229|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 277120 (271K) [application/octet-stream]
Saving to: ‘/tmp/composer-setup-XXXX.php’

/tmp/composer-setup-XXXX.php                   100%[===================================================================================================>] 270,62K  43,0KB/s    in 6,3s    

2020-04-27 19:03:24 (43,0 KB/s) - ‘/tmp/composer-setup-XXXX.php’ saved [277120/277120]

[email protected]:~# curl -LIs https://getcomposer.org/installer
HTTP/1.1 200 OK
Server: nginx
Date: Mon, 27 Apr 2020 19:03:56 GMT
Content-Type: application/octet-stream
Content-Length: 277120
Last-Modified: Wed, 12 Feb 2020 09:00:02 GMT
Connection: keep-alive
Vary: Accept-Encoding
ETag: "5e43be92-43a80"
Accept-Ranges: bytes

Even seems that I downloaded a temp wordpress installer a few days ago
Can you confirm permissions on /tmp/hestia-webapp are ok?

[email protected]:~# ls -lahtr /tmp/|egrep hestia
drwxr-xr-x   2 root  root  4,0K abr  7 03:19 hestia-webapp
[email protected]:~# ls -lahtr /tmp/hestia-webapp/
total 12M
-rw-r--r--   1 root root  12M dic 18 22:17 wordpress-5.3.2.tar.gz
drwxr-xr-x   2 root root 4,0K abr  7 03:19 .
drwxrwxrwt 124 root root  20K abr 27 18:58 ..
[email protected]:~# 

I can’t reproduce on a clean install (because I don’t have another server)
But,

  1. Enter to user if you have one. I tried with admin user.
  2. Select user
  3. Go to “WEB”, “QUICK INSTALL APP”, choose “Wordpress” or “Laravel” (that Is what I tried to install), select “Create DB” and leave default values.
  4. Click on “INSTALL”

/tmp/hestia-webapp folder is owned by admin user

ls -lahtr /tmp/|egrep hestia
drwxr-xr-x  2 admin admin 4.0K Apr 27 14:16 hestia-webapp

ls -lahtr /tmp/hestia-webapp/
total 24M
-rw-r--r--  1 admin admin  12M Dec 18 22:17 wordpress-5.3.2.tar.gz
drwxr-xr-x  2 admin admin 4.0K Apr 27 14:16 .
drwxrwxrwt 15 root  root  4.0K Apr 28 03:10 ..
1 Like

Thank you Lupu! I fix /tmp/hestia-webapp owner and (at least) Wordpress can be installed.

Sorry. I don’t remember see the alert on browser, and I was working hard .

1 Like