Quick install app Prestashop ERR_TOO_MANY_REDIRECTS

Hi, I wonder if anyone can give me a hint what’s going wrong here.
I’ve created a new domain, with php7_4 apache, proxy caching, letsencrypt ssl, and deleted all files from the public_html folder to be on the safe side.
I then used the Quick install app button to install Prestashop and it finished with a warning about overwriting files.
Now going to the http or https site is giving me ERR_TOO_MANY_REDIRECTS however, I can reach the /admin pager and log into my shop.

I have checked and even remove the .htaccess with no joy.
Did anyone ever install presta from the quick install app?

Please try to enforce SSL from the admin

Also you can try to uncheck the Enable automatic HTTP-to-HTTPS redirection in Hestia --> Domain

See maybe https://www.prestashop.com/forums/topic/179235-i-get-too-many-redirects-error-on-my-front-shop-page/


I am experiencing this behavior as well. However, I am also unable to get the Prestashop running properly on my nginx and PHP-FPM (No apache) setup at all. The quick installer works fine but when I launch Prestashop for the first time I can sign in and get to the back-end but I cannot access and make any changes in settings, modules, themes etc. due to 404 error. The front-end works only if no redirected to https otherwise I am getting error 404. I deleted all the .htaccess files I found within the installed folder but no luck there either.

I am using VestaCP - prestashop Web Template NGINX which I added manually because it’s been missing on HestiaCP, however, I get the same behavior when I use the default template anyway. Could you please have a look at the VestaCP (Prestashop template) and let me know what’s wrong with it?
You can access it here: OneDrive link (editable)

You can also see the errors I am getting here: OneDrive link

I am trying get it working on Ubuntu 20.04 nginx/1.19.2, MariaDB 10.4.14 and PHP-FPM (multi-PHP) I’ve tried all the PHP versions from 7.1 to 7.4 with no joy :frowning:

Automatic HTTP-to-HTTPS redirection disabled on that site! Using Let’s Encrypt SSL cert.

I would be more than grateful if you could at least point me to the right direction. I have googled it and tried to figure out for almost whole weekend but I couldn’t find any solution.

Thank you very much in advance.


Noticed the same issue disabling the “force” redirect option solved the issue. But hosting a webshop on http isn’t an smart idea…

1 Like