Quick Install App: some apps are greyed out on php-8.0

Hi Team,

I believe this question is trivial (my apologies) but I thought it would be better to clear out any doubt.

After a fresh installation of HestiaCP v1.6.2 on Ubuntu 20.02 LTS I noticed that the following Apps are greyed out and can’t be installed because they require PHP v7.4:




From the Settings section, however, I can see that I’m currently running v8.0 of PHP. It appears obvious that by ticking the checkbox next to php-7.4 I will then be able to install them. What’s your best recommendation? Leaving php-8.0 as it is? Enabling 7.4 or enabling 8.1 and waiting for when these APPs will be available on php 8.0+?

I know the above could be silly but I don’t want to enable or disable anything at the moment as our HestiaCP is already in production and we don’t have a testing machine “yet” where to experiment all these tweaks.

Thanks in advance.


Hesita runs fine with multiple php versions enabled.

I have multiple sites running PHP 8.1 and a few running PHP7.4 and it works fine.

Some apps currently don’t work at PHP8.0 or higher so enabling it doesn’t make sense

1 Like

Hi @eris,

As usual clear, concise and straight to the point. Thank you!

I have multiple sites running PHP 8.1 and a few running PHP7.4 and it works fine.

How can you configure HestiaCP so that I can use php-7.4 on webdomain1, webdomain2 and webdomain3 and php-8.0 on webdomain4, webdomain5 and webdomain6? I would assume you just enable php-7.0 and php-8.0 and then when it’s time to install an App in each domain, HestiaCP will decide which version of PHP to peak up, right? So for instance:

On webdomain1, webdomain2 and webdomain3 I install MediaWiki and on webdomain4, webdomain5 and webdomain6 I install WordPress. After that I believe I will end up to something like this:

  • webdomain1, webdomain2 and webdomain3 will be using PHP 7.4
  • webdomain4, webdomain5 and webdomain6 will be using PHP 8.0

Can you please confirm or correct the above?



Yes you can see advanced settings : Backend template


Cheers man. It worked!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.