Recieve mails on port is losts

Good day. I have SSL SMTP traffic enabled on port 465 and IMAP on port 995 on the e-mail server, which works well when used by the e-mail box but if someone sends e-mail from another e-mail box (from another server) to my so the message is received via port 25.
I found out by blocking ports 25 and 143 on the firewall for security, and after a while I found out that I didn’t get messages on the server. When I looked into the Firewall it is because the server receives messages on port 25 and not on port 465 even though SSL is enabled.
I tested sending a message to my server from gmail, where I have set up sending via port 465 as well, but this is not the case. I want to ask how can I solve this problem?

you need to leave port 25 open, its the basic communication port for emails and not all servers do use ssl yet.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.