Redis Installation | ERROR with phpx.x-redis & Integration with wordpress

I have installed the Redis on my server running hestiacp. by following steps,

1: sudo apt update
2: sudo apt install redis-server
3: sudo systemctl enable redis-server
4: vi /etc/redis/redis.conf [maxmemory 1024mb & maxmemory-policy allkeys-lru]
5: sudo systemctl restart redis-server
6: sudo apt install php-redis

Now as i researched in google and hestiacp forum, i have to install redis for particular version of PHP, to use it in latest version.

i tried following command as per guide but got error:

apt install php8.2-redis

tried another command as per another guide (step 3) and after tried to check is it installed or not:

Anyone please give guide to resolve the issue.
Also help me how can i perfectly integrate it with wordpress.?
and after intigration how can i check is it working and connected successfully?

and i have another some confusion, after installing redis, it will effect [decrease] my previous website performance or load speed?

tried with below command, site is running on php7.4
sudo phpenmod -v 7.4 -s ALL redis

Also tried with installation of
sudo apt-get install php-igbinary

Are you using Debian or Ubuntu? What version?

Show the output of this command:

grep -rE 'sury|ondrej' /etc/apt/

I am on Ubuntu 22.04

grep -rE ‘sury|ondrej’ /etc/apt/

That is the reason you can’t install php7.4-redis package, you are not using ondrej’s ppa, you have the lines commented in:


I don’t know why you have those lines commented but you should uncomment them and run sudo apt update and then you should be able to install the php7.4-redis package.

From which file i can uncomment this.
Whats the directory and file name.

From the files I wrote in my last post

thanks bro, issue resolved…

One more confusion, i am on ubuntu 22.04 mean jammy,

then i have to uncomment both lines or just first one.

1 Like

If you sre not using source packages with the first one is enough.

If you are using apache, remember to uncomment the line in the other file.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.