Regular/recurring email spam from Hestia about cron unable to resolve hostname


Starting May 27, I started getting email spam from Hestia (Cron Daemon) about it being unable to resolve my hostname (a subdomain). Here are some examples of emails:

I have disabled my ufw firewall, I can ping the subdomain as a regular user, I can sudo echo, and everything seems to be working fine except for these error emails. I have added the subdomain/hostname to my /etc/hostname to point to the IP address it actually resolves to (my VPS that Hestia currently resides on). Nothing seems to be helping. This was working fine for weeks and then it just randomly broke one day.

Are there any ideas anyone has, any logs I could check? It’s awful getting a ton of spam emails every 15 to 30 minutes for days on end.

Could this be a networking issue of my VPS provider (DigitalOcean)?

I would really appreciate any help, this seems like a super urgent and awful issue for me to get fixed… At this point I would honestly be willing to pay money for support to resolve this.

Thank you.

You could temporary cronjob in admin user (v-update-sys-rrd), but its clearly a lookup issue. Does a nslookup hestiapanel.yourdomain.tld work?

No this is a bug with in Hestia. We are working on a permanent fix.


Yeah, nslookup works fine both with and without a manual /etc/hosts entry of hestiapanel.mydomain.tld:

It only doesn’t work for cron it seems.

Execute the following commands in this order

rm /usr/lib/networkd-dispatcher/routable.d/50-ifup-hooks
rm /etc/iptables.rules
1 Like

For some reason the emails just started up again even though I didn’t change anything, so I think it’s still happening. Is there anything else I can try for now?

I at least feel better that this is a known issue and it’s being worked on, I appreciate all your guys hard work on this awesome project which has otherwise been working perfectly for me for months. :grinning:

edit: I tried


again and I think it might be working this time?

edit 2: the spam is still happening sadly

Sorry for double post but iptables isn’t even started and it’s still spamming me with emails:

Is it possible my issue is unrelated and is caused by something else?

We’re preparing a new (hotfix) release for tomorrow, all changes should already be in main branch. You could basicly run v-update-sys-hestia-git hestiacp main install, but just to be sure you need to run apt install --reinstall hestia after we released 1.4.2 - just to be sure you don’t have missed any changes.


Hi, a few days ago this problem began to happen to me, is it possible that it has happened again? Greetings

No, its not possible. Please do not revive a nearly one year old thread, create a new one and add as much informations as possible.