Remote DB for MariaDB - MYSQL

no cant problem remote connection, but is port 5003 and not 3306.


other company connection mariadb port 5003

Command arguments are:

TYPE HOST DBUSER DBPASS [MAX_DB] [CHARSETS] [TEMPLATE] [PORT]

So if you want to specify a different port and don’t want/need to configure MAX_DB, CHARSETS or TEMPLATE, add quotes to the argument position, something like this:

v-add-database-host mysql 199.xxx.xxx.xxx dbuser dbpass '' '' '' 5003
1 Like

Ohh, but werid same error “Error: MySQL connection to 199 failed” no idea much werid. is okay have ping worked:

64 bytes from 199.xxx: icmp_seq=1 ttl=47 time=31.0 ms
64 bytes from 199.xxx: icmp_seq=2 ttl=47 time=31.1 ms
64 bytes from 199.xxx: icmp_seq=3 ttl=47 time=31.1 ms
64 bytes from 199.xxx: icmp_seq=4 ttl=47 time=31.1 ms

Can you connect to port 5003?

telnet 199.xxx.xxx.xxx 5003

Yes correct:

— 199.xxx.xxx.xxx ping statistics —
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 31.047/31.078/31.111/0.027 ms
root@hestiacp:~# telnet 199.xxx.xxx.xxx 5003
Trying 199.xxx.xxx.xxx…
Connected to 199.xxx.xxx.xxx.
Escape character is ‘^]’.
p
5.5.5-10.3.18-MariaDB-1:10.3.18+maria~bionicp5U/&r,$���o#],_~}v[D#!mysql_native_passwordConnection closed by foreign host.

Then try first to connect using mysql client:

mysql -u USERNAME -pPASSWORD -h HOSTNAME -P 5003 
1 Like

hmmm is example mysql -u root -pass -h name.com -p 5003 right?

well check commands.

The password is after option -p without spaces, for example, if your password is secret, the argument will be -psecret or use only -p and it will ask for the password.

root@hestiacp:~# mysql -u root -password -h 199.xxx.xxx.xxx -P 5003
ERROR 1045 (28000): Access denied for user ‘root’@‘45’ (using password: YES)

If you want to connect to the remote db with user root, first you must be sure to allow the user root to connect to that db from your remote machine.

explain first: root and pass done and add -h 199.xxx.xxx.xxx -P 5003

correct?

OR mariadb root and pass and -h and -p?

Sorry, I don’t understand what you mean. The command is

mysql -u root -pHereTheRootPasswordForRemoteDB -h 199.xxx.xxx.xxx -P 5003

But as I said, root user must be allowed to connect from your machine, it usually is only allowed to connect from localhost.

2 Likes

Hmm think mariadb remote yeah is:

root@hestiacp:~# mysql -u root -passremotedb-h 199.xxx.xxx.xxx -P 5003
mysql: unknown option ‘-5’

Or my vps mysql?.

I suppose your password has these characters -5, use -p'password' or as I said, use only -p and it will ask for the password.

ahh forgot -ppass okay!

only vps hosting:

root@hestiacp:~# mysql -u root -p -h 199.xxx.xxx.xxx -P 5003
Enter password:
ERROR 1045 (28000): Access denied for user ‘root’@‘45.xxx.xxx.xxx’ (using password: YES)

mariadb hosting (but is okay have is port 5003)

Okay but investigate diffcutly explain and use anydesk or zoom or discord my desktop live.

Solution support mariadb hosting fix.

and done add.

and how is delete list database host?

uhh what…
image
well think max 32 okay.

now problem Error: Connection to 199.xxx.xxx.xxxfailed

Closed comments check: [Bug] database remote failed · Issue #4332 · hestiacp/hestiacp · GitHub