Remove ClamAV from VPS

Hi, i want to remove ClamAV from Hestia.
to much CPU usage in all time/ 90-99%
How to remove or complete disable ClamAV

First thing to do is edit your exim config so it doesn’t complain when you stop clam. Find the line at the top which activates it and comment that out.
#CLAMD = yes
Restart exim and check that its working.

systemctl restart exim4
systemctl status exim4

And check you’re receiving mails normally, and there are no errors in /var/log/exim4/mainlog

If that all looks good, you can stop the clamav service.

systemctl stop clamav-daemon.service 
systemctl stop clamav-freshclam.service
systemctl disable clamav-daemon.service 
systemctl disable clamav-freshclam.service

Once again, check that you’re receiving mail, no errors in logs.

Maybe wait a few days. If you’re absolutely sure its all working, you can use apt remove or apt purge to uninstall clam.

Finally you may want to go into the control panel and edit each mail domain to disable Antivirus for that domain.

And then you may also want to change the entry in /usr/local/hestia/conf/hestia.conf
ANTIVIRUS=""
I think Hestia will still work without those last steps, but it keeps things tidy. Maybe one of the developers will add anything I missed.

1 Like

Work perfect. Thanks


High CPU usage from clamscan?

Strange. htop says 100%, but the 8 core bars at the top tell a different story.
I guess if you’ve disabled clam and fresclam, you could just kill the process
(highlight in htop, then hit k and select SIGTERM. Or SIGKILL if it refuses to die)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.