Remove SNI from domain

Will running the v-change-sys-ip-owner command move the IP from the admin panel domain to the main .com domain so the main .com domain no longer shows an SNI error in SSLLabs?
I tried switching the IP from shared to dedicated but received an error when trying this in the panel.

There is only 1 domain + a sub domain on the site. The panel is server.domain.com for panel login secured with Let’s Encrypt, and the domain is the same .com secured with a paid SSL. When running the server.domain.com through SSLLabs, SNI isn’t present nor is the SNI error. However, when running the .com through SSLLabs the SNI error is present.

I understand that you don’t want your domain to use SNI. Since SNI is already mature and supported by almost all current software, may I ask why you don’t want it?

And what is that SSL Labs error you mentioned?

Hi @Felix. Being on a dedicated server, and SNI is still not a thrill for ecommerce processors, throwing an SNI error says ‘shared IP’ which we’re not using.

It seems since the IP order on HestiaCP is server.domain.com first (setup when first installing the panel with LE) and appears to own the IP and the basic domain.com which is shared and owned by the user shows this error: Alternative Names: server.domain.com MISMATCH .

The error doesn’t occur when scanning the domain.server.com with SSLLabs, just when scanning the domain.com SSL.

No issues with the 2 SSLs (Sectigo and Let’s Encrypt) and the panel is absolutely amazing (we love using it), just hoping to avoid the SNI issue without a secondary IP. :slight_smile: