Resolved re: Restore admin backup from another Hestia or Vesta server

#1

I am thinking of switching from my Vesta at [Hostwinds] to Hestia, which has the force-ssl feature built in - I like it a lot. So I was testing HestiaCP on one server yesterday. Because the fresh install worked right after installation, I decided today to set it up on another server and testing if I can restore the admin backup on the new server.

I followed simple instructions given here: https://vestacp.com/docs/#how-to-migrate-user-to-another-server

But when tried to restore it using the command given, I got this error:

Error: backup admin.2019-05-08_19-04-47.tar doesn’t exist

The folder /home/backup and the file in it both exist and have the root:root permission settings.

#2

OK, I got the command v-restore-user to work with the file by giving the path to it:

v-restore-user admin /home/backup/admin.2019-05-08_19-33-45.tar

but then I got this error:

Error: invalid backup format :: /home/backup/admin.2019-05-08_19-33-45.tar

Strange, this is Hestia backup and restore without involing Vesta to Hestia retore. Why invalid backup format? I even tried to remove the _19-33-45 part in the finename, but the same error.

#3

OK, I changed to /home/backup folder and then use this command to run the restore OK:

bash -x v-restore-user admin admin.2019-05-08_19-33-45.tar

But then when I check the situation in the panel on new server, nothing gets restored. I even reboot the server after restoration. No luck.

#4

The script run but I got quite a few instances for this error:

‘backup admin.2019-05-08_22-11-28.tar doesn’’‘t exist’

#5

OK, found a solution at the last post entry at https://forum.vestacp.com/viewtopic.php?t=5399

Basically the backup folder is one level up from /home, so the second command line should be:

scp /home/backup/admin.2014-01-14.tar new-server:/backup/