Restore DB still waiting after 45mins after Update 1.7.0

This morning I had to restore DB for one client, I have been waiting over 45mins for the email to confirm it’s restored.
If I try restore again it tells me “An existing restoration task is already running. Please wait for it to finish before launching it again.”

To see if the Import is stilll running use top and check if mysqldump is still working

You can delete /usr/local/hestia/data/queue/backup.pipe and you should be able to run it again

Hi Eris,
mysqldump not showing in top.
Can I still stop the backup.pipe or do I need to do something else first?

I’ve removed backup.pipe and run it again, 40 mins and still not restoring.
This db restore is only 15mb and usually only take less than 5mins to finish. :exploding_head:

If I run from cli v-restore-database USER BACKUP DATABASE it restores in seconds, however from admin this function hangs.

The reason for restoring database is that max_input_vars has defaulted back to 1000 even though I had this set to 100000. The php.ini has disabled the new setting reverting back to the default.

v-restore-database calls v-restore-user … So that is strange …

very strange, when running cli command i get the email restored but nothing when restoring from admin, it wouldn’t have come to light had php.ini not reset to default settings
In the past when restoring a user database from admin it normally takes a few seconds.
I have also tried a restore DB (size 1mb) from admin on a test site, this has not restored 20mins and counting.
It appears there is an issue with admin backup/restore side.

At this point I would like to note that the database is not readable with an editor if you have set zstd as compression. Why is that? For this reason I always use gzip. Probably this will not be part of this problem.

Hi Meister,
Not sure if your reply is for this topic.

A quick update.
Noticed this morning that all backups had failed.
I rebooted Hestia then ran a quick backup, all worked.
A reboot seems to have solved the problem.

Thanks again eris for your help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.