[email protected] is undeliverable: Unrouteable address

My exim log is full of these, and the queue is full of frozen messages because of that;

2023-02-09 10:51:44 1pQ3ai-0003Rf-9G <= [email protected] U=root P=local S=680
2023-02-09 10:51:44 1pQ3ai-0003Rf-9G ** [email protected]: Unrouteable address
2023-02-09 10:51:44 1pQ3ai-0003Rj-Ae <= <> R=1pQ3ai-0003Rf-9G U=Debian-exim P=local S=1970
2023-02-09 10:51:44 1pQ3ai-0003Rf-9G Completed
2023-02-09 10:51:44 1pQ3ai-0003Rj-Ae ** [email protected]: Unrouteable address
2023-02-09 10:51:44 1pQ3ai-0003Rj-Ae Frozen (delivery error message)

I already tried this in exim4.conf.template:

domainlist local_domains = @:localhost:$primary_hostname:dsearch;/etc/exim4/domains/

but to no avail.
I would like to route mail for [email protected] to [email protected]

How do I go about this?

By the way, this is a default clean debian 11.6 install of hestiacp, so I reckon many users will have this problem. It’s a problem because it can cause Log Failure Daemon (CSF/LFD) or fail2ban false positives, and it deprives you of sometimes important system warnings.

Create a mail domain with host.domain.com and add and create a “email” account with root:

Instead Discard all mail you need to select Do not store forwarded mail

And it should work fine

( I tried that already… several ways) hestia tells me:

Error: mail domain my.domain.tld doesn’t exist

The hestia error log:

2023-02-09 11:50:16 v-add-mail-domain  'userx' 'my.domain.tld' 'yes' 'yes' 'no' [Error 4]
2023-02-09 11:50:16 v-add-mail-domain-reject  'userx' 'my.domain.tld' 'yes' [Error 3]
2023-02-09 11:51:10 v-list-mail-domain  'admin' 'my.domain.tld' 'plain' [Error 3]
2023-02-09 11:51:11 v-list-mail-domain  'admin' 'my.domain.tld' 'plain' [Error 3]
2023-02-09 11:51:11 v-add-mail-domain  'admin' 'my.domain.tld' 'yes' 'yes' 'yes' [Error 2]
2023-02-09 11:51:11 v-add-mail-domain  'admin' 'my.domain.tld' 'yes' 'yes' 'yes' [Error 4]
2023-02-09 11:51:11 v-add-mail-domain-reject  'admin' 'my.domain.tld' 'yes' [Error 3]

Note that my.domain.tld is the main hestiacp domain name. (I replaced the original name with my.domain.tld).

domain.tld (so, without the my subdomain/hostname) belongs already to userx and works.

Error: Unable to add my.domain.tld. domain.tld belongs to a different user

and when I try and create it under that different user:

Error: Web domain my.domain.tld exists

This also relates to the ability to have/use email domain aliases. If we would be able to make my.domain.tld an alias of domain.tld all would be fine…

Add it under the admin user there is a check to prevent users to add domain.com as mail domain under a different user

never mind, this was my fault.
I had earlier created an alias symlink to try and route exim mail under /etc/exim4/domains

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.