Rouncube configuration lost due to package upgrade

Thank you @ScIT
I still have problem with server

what need to put there?

Try localhost but it is new for me?

Could you check


I dont think this is related to the hestia rc - is it possible that you also upgraded the rouncube package? There seems to be a issue that the config gets overwritten.

Yes, i did an upgrade
How can I fix that?

 cp -f $HESTIA_INSTALL_DIR/roundcube/ /etc/roundcube/
 chmod 640 /etc/roundcube/
 chown root:www-data /etc/roundcube/

$HESTIA_INSTALL_DIR = /usr/local/hestia/install/deb/


at Debian 10:
just run at root:
apt-get -t buster-backports install roundcube
during install upgrade, you need boot config sugestions, whit NO answer, that all

just wondering that is possible for ubuntu 20.04
anyone already tested yet?


no, because the buster-backport repo isnt available on ubuntu.

aa…i see
thanks @ScIT

any idea how update/upgrade roundcube version ?

Yes, for Ubuntu tray upgrade whit change php settings in php.ini and run upgrade whit sh , make etc install from roundcube dir. I use this way couple weeks ago but i forgot web url adress whit the step by step info. Search pleasse self. This works for Ubuntu 100%. But after success, change php.ini back becouse this way leave security reasons intro php.

I don’t have exact instructions, but the three locations where things happen are here.

  • the actual program files are downloaded to /usr/share/roundcube/
  • the config happens in /etc/roundcube
  • the web directory is in /var/lib/roundcube, which contains symlinks to the above locations. This is the one you add to your nginx / apache config.

If you back all those up before you start, then you can try installing a new version of roundcube from here.

It will break! Guaranteed. Then its up to you to figure out how to point to the correct config files, or roll back to your backup. Currently I see Roundcube 1.4.3 is installed, and 1.4.9 is the latest, so if there’s nothing compelling in 1.4.9, just leave it alone.