Roundcube will not work after Hestia installation

I have a little experience with Hestia, but am by no means an expert. I am trying to set up a mail server for multiple domains on a new VPS server. The website for the domwing are hosted on a completely different server with another hosting provider.
I have installed Hestia on th server. After installation, Rooundcuvb won’t work. When going to the mail.mydomain.com the Success message appears.


Cloudflare is hosting the DNS configuration, which I set up myself, and this could be the part of the problem.
When I enter the IP address into the browser, I get the same Success screen. The index.html for this resides in /var/www/html/ not the usual /home/admin/web/mydomain/public_html. This was confirmed by putting a php file in the folder and running it.
When I enter mail.mydomain into the address bar of the browser, it converts to webmail.mydomain, but I still get the success screen. Trying to run the php file from these gets a 404 message.
I have searched for a solution on the forum, and while many others report the Success screen, their solutions have not worked for me.
Please help.

Why do you think so?

Note: I’ll replace mydomain by example.com

Did you add a mail domain for example.com?

Show the output of this command (replace YourUser by the actual user and do the same for the domain):

cat /home/YourUser/conf/mail/example.com/nginx.conf

Hi @sahsanu, thanks for responding. Here is the output:
server {
listen 107.173.nn.nnn:80;
server_name webmail.my_domain.com mail.my_domain.com;
root /var/lib/roundcube;
index index.php index.html index.htm;
access_log /var/log/nginx/domains/webmail.my_domain.com.log combined;
error_log /var/log/nginx/domains/webmail.my_domain.com.error.log error;

include /home/admin/conf/mail/my_domain.com/nginx.forcessl.conf*;

location ~ /\.(?!well-known\/) {
	deny all;
	return 404;
}

location ~ ^/(README.md|config|temp|logs|bin|SQL|INSTALL|LICENSE|CHANGELOG|UPGRADING)$ {
	deny all;
	return 404;
}

location / {
	alias /var/lib/roundcube/;

	try_files $uri $uri/ =404;

	proxy_pass http://107.173.nn.nnn:8080;

	location ~* ^.+\.(ogg|ogv|svg|svgz|swf|eot|otf|woff|woff2|mov|mp3|mp4|webm|flv|ttf|rss|atom|jpg|jpeg|gif|png|webp|ico|bmp|mid|midi|wav|rtf|css|js|jar)$ {
		expires 7d;
		fastcgi_hide_header "Set-Cookie";
	}
}

location @fallback {
	proxy_pass http://107.173.nn.nnn:8080;
}

location /error/ {
	alias /var/www/document_errors/;
}

include /home/admin/conf/mail/my_domain.com/nginx.conf_*;

}

I have replace the domain name with my_domain, and the ip address with nn.nnn.

Your help is very much appreciated.

Your webmail subdomain is pointing to ip 159.x.x.x instead of 107.x.x.x, you should modify the A record to point to the right ip.

Thanks
I have done that. Roundcube still does not work, and the website is now also not functional. Here is the output from the cat command:
server {
listen 107.173.x.x:80;
server_name webmail.my_domain.com mail.my_domain.com;
root /var/lib/roundcube;
index index.php index.html index.htm;
access_log /var/log/nginx/domains/webmail.my_domain.com.log combined;
error_log /var/log/nginx/domains/webmail.my_domain.com.error.log error;

include /home/admin/conf/mail/my_domain.com/nginx.forcessl.conf*;

location ~ /\.(?!well-known\/) {
	deny all;
	return 404;
}

location ~ ^/(README.md|config|temp|logs|bin|SQL|INSTALL|LICENSE|CHANGELOG|UPGRADING)$ {
	deny all;
	return 404;
}

location / {
	alias /var/lib/roundcube/;

	try_files $uri $uri/ =404;

	proxy_pass http://107.173.x.x:8080;

	location ~* ^.+\.(ogg|ogv|svg|svgz|swf|eot|otf|woff|woff2|mov|mp3|mp4|webm|flv|ttf|rss|atom|jpg|jpeg|gif|png|webp|ico|bmp|mid|midi|wav|rtf|css|js|jar)$ {
		expires 7d;
		fastcgi_hide_header "Set-Cookie";
	}
}

location @fallback {
	proxy_pass http://107.173.x.x:8080;
}

location /error/ {
	alias /var/www/document_errors/;
}

include /home/admin/conf/mail/my_domain.com/nginx.conf_*;

}

You must do two things:

1.- Due a bug, permissions for roundcube are not the right ones so execute these commands to fix them:

chown -R hestiamail:www-data /etc/roundcube/
find /etc/roundcube/ -type f -iname "*php" -exec chmod 640 {} \;
chown -R hestiamail:www-data /var/lib/roundcube/
chown -R hestiamail:www-data /var/log/roundcube/

2.- You must get a certificate for your mail domain:

1 Like

Why you changed webmail to 159.x.x.x again? It must point to 107.x.x.x and it was a few minutes ago.

I have changed the webmail back to 107.x.x.x Sorry. Should not be trying to fix two things at the same time.

I have followed your instructions. Roundcude is still not working. Here is the output from the cat command:
server {
listen 107.173.x.x:80;
server_name webmail.my_domain.com mail.my_domain.com;
root /var/lib/roundcube;
index index.php index.html index.htm;
access_log /var/log/nginx/domains/webmail.my_domain.com.log combined;
error_log /var/log/nginx/domains/webmail.my_domain.com.error.log error;

include /home/admin/conf/mail/my_domain.com/nginx.forcessl.conf*;

location ~ /\.(?!well-known\/) {
	deny all;
	return 404;
}

location ~ ^/(README.md|config|temp|logs|bin|SQL|INSTALL|LICENSE|CHANGELOG|UPGRADING)$ {
	deny all;
	return 404;
}

location / {
	alias /var/lib/roundcube/;

	try_files $uri $uri/ =404;

	proxy_pass http://107.173.x.x:8080;

	location ~* ^.+\.(ogg|ogv|svg|svgz|swf|eot|otf|woff|woff2|mov|mp3|mp4|webm|flv|ttf|rss|atom|jpg|jpeg|gif|png|webp|ico|bmp|mid|midi|wav|rtf|css|js|jar)$ {
		expires 7d;
		fastcgi_hide_header "Set-Cookie";
	}
}

location @fallback {
	proxy_pass http://107.173.x.x:8080;
}

location /error/ {
	alias /var/www/document_errors/;
}

include /home/admin/conf/mail/my_domain.com/nginx.conf_*;

}

Are you sure?

I have just managed to get the Roundcude login screen. Not sure why it did not work a minute ago.
Thanks for the help. I will now test to see whether I am able to send and receive emails.

1 Like

I am now able to send and receive emails. Thank you for your assistance.
You’re a hero.

1 Like

You are welcome :partying_face:

Just two things:

1.- Remember to create the TXT record for _dmarc

2.- There is no need to add three MX records pointing to the same mail domain, remove two of them.

As you have probably gathered by now, I’m a novice when it comes to setting up the DNS records. Item 2 is simple. Can you please provide some guidance on item 1.
I also have a different problem with Hestia that I’d like your assistance with. For some reason it limits me to one email address, and one domain, and one email domain. When I try to add more users, it tells me to upgrade. I’ve looked on the Hestia website, and it makes no mention of upgrades. Can you assist, or should I open a new topic. Thanks again.

Create a TXT record for subdomain _dmarc with this text:

v=DMARC1; p=quarantine; pct=100

How are you trying to add more users? What is the package you are assigning to those new users?

I am trying to add more email accounts, and more email domains. At present Hestia indicates that there is a limit of 1 for for email accounts and 1 for domains.

Then you need to create a new package with the limits you need and assign it to that user or change the limits to the actual package assigned to that user.

When I try and add an email account, this the message that I get:


These are not new packages. All the packages were installed when Hestia was installed.

:slight_smile: I’m talking about these packages:

imagen

Thanks, that sorted it out. I did not realise that a user is assigned to a package. After adding the package, and changing the user to that package, the limits are defined by the new package.
That’s twice today you have saved me. It’s really appreciated. Hope I can return the favour sometime.

1 Like