Set Exim to listen only on localhost

Hi,

As I need Exim only to send outgoing emails, I was wondering if it’s possible to set it listening only on localhost (127.0.0.1).

Thanks for any help!

Try adding:
dc_local_interfaces='127.0.0.1'

to /etc/exim4/exim4.template.conf

And then restart exim4

Restarting Exim, an error shows up:
missing rewrite replacement string

Does it include a line number?

Exim configuration error in line 414 of /var/lib/exim...

Check where line 414 and forward …

You mean checking this file? /var/lib/exim4/config.autogenerated.tmp

This is the output at line 414:

413
414 dc_local_interfaces='127.0.0.1'
415```

Maybe check:

Hi @eris

Didn’t manage to change the listening interface… it’s still listening on 0.0.0.0
Are you sure that this directive must be added to exim4.conf.template and not to update-exim4.conf.conf instead?
BTW in this last file, there’s already an entry like this:
dc_local_interfaces='127.0.0.1 ; ::1'
I’ve also tried to change it to dc_local_interfaces='127.0.0.1' but nothing changes…

I never disabled it. It was the first result in Google…