Setting of quick install of nextcloud

Hello dear community,
I use hestia quick install feature to install nextcloud. I’m wondering where I could find all the settings for next cloud. I’d like to do some tweaks/adjustments (e.g. to add HTTP “Strict-Transport-Security” for more security…) I just can’t find the config file in /var/www , ~/web/… or /etc/apache2/site-available.

You have that option in:

Web -> Edit web domain -> Enable SSL for this domain -> Enable HTTP Strict Transport Security (HSTS)

1 Like

Thnak you for your reply. I enabled the HSTS and the warning disappeared. However, it still shows many other warnings like “memcache should be enabled” and “PHP OPcache module is not properly configured”…

Take a look to how-can-i-change-settings-for-a-specific-domain

1 Like

Keep in mind that most of those warnings could be ignored if you won’t be use nextcloud as a heavy user or for lots of users.

Anyways, to “resolve” the memcache/opcache warnings, you should install several php modules and also redis server for file_locking. The php modules should be installed for the php version nextcloud is using, I will show an example using Debian 12 and php 8.2:

As root:

apt install php8.2-apcu php8.2-redis redis-server

Once installed, edit your nextcloud config.php file (/home/YOURACCOUNT/web/YOURDOMAIN/public_html/config/config.php) and add the following lines before the last line );

  'memcache.local' => '\\OC\\Memcache\\APCu',
  'filelocking.enabled' => true,
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
    'timeout' => 0.0,

Maybe you would also want to rise opcache.memory_consumption to something like 128M or 256M… or whatever you could need, to do so, edit the .user.ini file of your domain ((/home/YOURACCOUNT/web/YOURDOMAIN/public_html/.user.ini) and add this:


Once done, restart your php-fpm service for your php version, in my case:

systemctl restart php8.2-fpm.service

Note, I’m using only nginx+php-fpm, if you are using nginx+apache+mod-php or php-fpm, the steps could change.

I hope this helps.



Thank you so much for the valuable answer. :smiley: There are some settings need to added/adjust to a config file for the domain. Default: /etc/apache2/sites-available/MYDOMAIN. Something like <VirtualHost *:80>… DocumentRoot… and such such… There is no such file and even if I create that file, it’s not used. I’m wondering where the file for a domain sits. By your answer, it seems it’s in /home/MYACCOUNT/web/MYDOMAIN/public_html/ I should also put that in .user.ini or the .htaccess. I guess it’s .htaccess file since it uses mark up thingy or I should also put the apache settings in .user.ini file???
There’s not much said in the doc for that .user.ini file and how to use it. (what’s accepted and restrictions…etc)
THank you :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.