Sieve not working after Updating to 1.8.5

Hello, i’ve recently updated my Hestia instance from VERSION: 1.7.8 to VERSION: 1.8.5. After the update, I received a notification indicating that the Exim config couldn’t be patched. In response, I visited a relevant forum thread located at Exim upgrade has screwed up the config file. Exim not starting. In order to address the issue, I utilized the provided config template for my exim4 version, making sure to uncomment the Clamd and SpamAssassin configurations.

This approach resolved the majority of the issues, with everything functioning properly. However, I have encountered a problem with Sieve not functioning as expected. I’m wondering if running the Sieve install script again might resolve this particular issue. Could you please advise me on the best course of action to resolve this matter?

I had the same issue. Ran the Sieve script twice to first uninstall, and then reinstall again. Worked like a charm

/usr/local/hestia/install/upgrade/manual/ (this one)

1 Like

Does the uninstall process delete the configured filters? I ask because I’m working with a client who currently has more than 30 filters already set up.

It didn’t delete mine, however I would strongly advise you backup the server either way

You can also download filters directly from Roundcube

1 Like

Thank you for the assistance; it worked perfectly!

Stock exim templates don’t come with Sieve enabled… That is why

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.