SMTP doesn't use Encryption

Hey, My Mail Domain is Secure with Let’s Encrypt SSL.

But when I am trying to connect email via SMTP in thunderbird, Its detecting STARTTLS for Imap and None for SMTP. and I am getting this a “ does not use encryption” How do I fix the issue?

Use in both cases

oh yeah that’s completely on me. Thunderbird keeps changing the outgoing server to even if I put it I have no idea why

It’s still not working. I gave up thunderbird since it keeps changing stmp to

I am using another client called emclient and facing the same issue

I copied all the settings provided on the right side in hestia panel mail settings

Delete the smtp dns record and it should work fine

Deleted STMP from dns, retried, no luck

Maybe cloudflare in place?

1 Like

you didn’t write correctly

try and not stmp.

this address should be present (you have to add it) in DNS records of the domain

Cloudflare doesn’t proxy mail server.

Yeah my bad. The actual server was Thunderbird kept changing it automatically for some reason. So I switched to EMclient.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.