SMTP for internal emails not working

I am trying to receive hestia internal emails like admin password reset, panel update notification, send new user welcome email etc.

Followed instructions shared in this thread Set up SMTP to receive HestiaCP server's internal email

I have setup smtp details in global smtp control panel settings and in this script

/usr/local/hestia/install/upgrade/manual/ the is a file located run there this script and follow the instructions.

In the script there is an option ‘SMTP security’ please explain what i should fill in that. Rest of the options are standard smtp settings.
Also the email in that script I guess will be the main sender email.

Currently I am not able to receive any internal email from server.

bump. Please if anyone can help troubleshoot this issue?

SSL or TLS are the most common options

I have tried with ssl, tls for port 465 , 587 but its not working and /var/log/exim4/mainlog gives permission denied error. should not send email with exim but we send email via phpmailer

Okay so where should I check or how to troubleshoot this.

I have updated smtp setting in configure>mail> global smtp relay

I have not set smtp relay settings for individual domains. Should I do that? but how that will help sending internal emails.

I have even tried with short/weak login credentials as some services have problem with lengthy password but it just doesn’t work.

So I tried this on a fresh hestiacp with 2 different smtp providers.

When adding user with welcome email it uses smtp I think or maybe it was for backup notification or something.

in exim mainlog it shows this error

Message is frozen

Upon checking exim queue it is sending emails to root.

<[email protected]> *** frozen ***
          [email protected]

How can I use my admin user email for system emails?

I cleared the exim queue and tried sending a new user welcome email and password reset but still its not working and nothing in exim4/mainlog
Edit: okay so hestia uses phpmailer for internal emails but how do I configure that now? Please help.

I am using port 587 now earlier it was the issue I think because my host blocks 25 and 465

I am not using spamassasin only clamav

This script will setup phpmailer to use for email…

I have already configured this

        Use SMTP: true
        SMTP Host: smtp.xxxx.xx
        SMTP Port: 587
        SMTP Security: tls
        SMTP Username: xxxxxxxx
        SMTP Password: xxxxxxxx
        Email Address: [email protected]

okay so this is a little embarrassing and some bad luck which made me waste so much time on this.

SMTP 1 - I forgot to whitelist new server ip so authentication was failing, smtp provider didn’t mentioned this anywhere in their error code docs.
SMTP 2 - I didn’t used this since a while so they paused my account and were suppressing emails.

When I figured the problem with SMTP 1 their server at the exact time had some issue and no emails were processing even though it was showing sent.

Now some emails are working using

  1. New user welcome
  2. Backup notification
    Update notification should also work as reported by another user.

But Password reset emails are not getting sent nor it’s showing in exim log (it is not sent by exim)
I guess this is a bug as reported by another user Control Panel Password Reset email not sending

Global smtp relay is well another thing which I will try to figure out later as all messages were getting stuck in exim queue with defer (-53) error, for now I have disabled global smtp relay. I am using same credential for configure-server-smtp script so the smtp host is reachable and the domain is also whitelisted.

defer (-53): retry time not reached for any host for ''

I think this is only partially solved for your case, because the password reset email issue is still unknown, same as what happened to me. Was planning to do clean setup with exim and others, but you saved me time since it’s still not solving the password reset email issues. Thanks to you!

@harris yeah there is some issue with the password reset email. I don’t know if password reset gets triggered properly there is no confirmation on screen. As you mentioned it throws an error to try after another 15 minutes if you try again.

To add to the list: Database credentials email is also working.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.