Snappymail with sieve

i try to install snappymail with sieve, i follow the instruction given in official documentation.
but when i try to open my webmail after setting snappymail as mail client it shows:
[202] Data folder permissions error [is_readable]
i follow this steps from documentation:

  1. v-add-sys-snappymail

  2. /usr/local/hestia/install/upgrade/manual/

  3. Open port 4190

  4. nano /etc/snappymail/data/data/default/domains/default.ini

  5. sieve_use = On
    sieve_allow_raw = Off
    sieve_host = “localhost”
    sieve_port = 4190
    sieve_secure = “None”

  6. save default.ini file

  7. i change email client from roundcube to snappymail in hestia control panel for my mail server.

i also note down detail in .snappymail file.

but then this happen

please help me where did i go wrong, what mistake i did.

Update the owner of /etc/snappymail to hestiamail instead of www-data

1 Like

Thanks sir.
It’s really work perfectly.
First I think thank maybe owner will set to be root because I see that roundcube directory owner is root, so I set roo as owner of this directory.
Then I see that setting owner root is also wrong. That’s why I ask her to get professional advice.
And find out that owner need to be “hestiamail” it’s new to me.
Not it’s all good after set owner to hestiamail as per given your solution.
Again thanks sir @eris for helping me everytime. :slightly_smiling_face:

Note: if sir you put this solution in documentation it will really helpful for new user (set owner to hestiamail if it not set by default).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.