[SOLVED] After adding extra IP & restart Hestia: APACHE2 and NGINX down

Hi there, newbie with Hestiacp
I found no solution for my issue:

=> clean standard install Hestiacp (bash hst-install.sj) on Debian 10 in lxc container Proxmox 6 (not unprivileged)
in Hestiacp: Adding extra IP with subnetmask & eth0 (both same as main)
==> I can ping that extra IP from outside
All services up & running

After a restart Hestiacp in panel Apache2 and nginx are down.
I cannot restart those services in panel.
Also not after reboot container

When I delete the extra IP again Apache2 and nginx going up again instantly (without restart)

Already did:
Deleted new IP and retry with v-add-sys-ip
==> v-list-sys-ips shows both IPs, after restart result is the same (nginx and Apache2 down till i remove 2th)
manualy added to etc/hosts

Hope somebody can help me to the right direction.tx

Im having the same issue. It would be nice to know where to look to sort this out. I checked files as best I could but I’m not sure where all the Nginx related conf files are stored.

Try run nginx -t

Just tried once but had no issues please supply some more details so we can test and find out what the cause is.


I’m not sure what to supply. I can’t find anything specific in the logs and all the config files seem fine. If I start apache, it will start lone, then try nginx and it says the port is already in use. Shutdown apache and then start NGINX and I then can’t start NGINX. There is nothing in the logs other that the port issue but I have not changed anything in weeks:

[emerg] 14744#14744: bind() to failed (98: Address already in use) replaces my IP.
I can’t get hestia up either . I get the same for port 8083

same problem (from nginx error log):
[emerg] 205#205: bind() to failed (99: Cannot assign requested address)

(remark:read as the new added ip)

Try ssl - nginx error: (99: Cannot assign requested address) - Stack Overflow

/etc/sysctl.conf file:

# allow processes to bind to the non-local address
# (necessary for apache/nginx in Amazon EC2)
net.ipv4.ip_nonlocal_bind = 1

and then reload your sysctl.conf by:

$ sysctl -p /etc/sysctl.conf

1 Like

@eris You are a true hero :slight_smile: That did the job !!

Also for other people (Proxmox)
you have to enable in “options”: nesting=1 after create your LXC container

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.