[Solved ] Error when upgrading to HestiaCP 1.6.0

Hello good evening.

I have Debian 11, and when I try to update Hestia to its new version 1.6.0 it gives me the following error.

`Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 hestia : Depends: idn2 but it is not installable
E: Unable to correct problems, you have held broken packages.`

It happens to me with 2 servers that I have, and the “idn2” package is installed.

apt remove idn2

and the

Try to install the update?

Do you try to install it over dpkg -i hestiaiupdate deb? If yes, trigger an apt install -f.

If no, check if you can install idn2 manually using apt install idn2

That’s it… thanks to Eris’s response, I was able to look better, and I saw that I had 2 update repositories stopped.

I have re-enabled them, and it has already worked correctly and without any kind of problem.

Thank you very much, it is a pleasure to have your help, always responding quickly.

Thanks.

2 Likes