Solved:How to fix ERR_TOO_MANY_REDIRECTS on Cloudflare

Changing SSL/TLS encryption mode to Full

Encrypts end-to-end, using a self signed certificate on the server

From the default :

Encrypts traffic between the browser and Cloudflare

Solved the redirect problem for me

Do not be afraid to poke around with the other Cloudflare transport settings as well

Using certificates from a globally trusted CA or the Cloudflare Origin CA and the Full (Strict) setting is the best option.


I had the too many redirects errors using the Let’s Encrypt SSL script option offered by Hestia. It did not affect all domains but did seem to shift from 1 domain to another domain. But never on multiple domains. ( Some had the full setting already configured) The previous topic ( on the forum ) was NEVER answered properly. The respondent never suggested any leads on trouble shooting. A lot of people are not experts in transport security behaviors and it would help if response to topics were at least mindful of the hair pulling that goes along with installing and configuration. I hope my specific response helps others that are using the default options offered in the control panel. Cloudflare caches and cuts down on server requests among other things and services that they offer. Compatibility with Cloudflare is a necessary component these days

Cloudflare in “Flexible” mode is buggy as hell.

The idea is great for websites without ssl but often how it is processed by many web servers it is only causing issues.

1 Like

Since Flexible only sends HTTP requests to the origin, it creates in an infinite loop when the origin server has an HTTP to HTTPS redirect in place.

The use of Flexible is strongly discouraged in the Cloudflare Community.

Cloudflare Community Tutorials

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.