Solved: Max download size; download dies at 1.08gb

Help appreciated! HestiaCP 1.8.7, I’ve got a website running WordPress. I have a large file I’m testing a download with at public_html/downloads/

For whatever reason it always dies at 1.08gb (the file is 2gb). I’ve tried mod’ing the my site nginx and apache definitions to include client client_max_body_size (nginx) and LimitRequestBody (apache) to be 3gb. I’ve also tried increasing timeouts for the public_html folder to be 10 minutes (more than enough for my server connection speed):

    proxy_connect_timeout 600s;
    proxy_read_timeout    600s;

But it still times out at 1.08gb. I’m not sure what’s going on here. Out of curiosity I checked downloading my backups which exceed 2gb for the given website. Downloading a backup larger than 2gb through HestiaCP works great. So I know my server is capable. I’ve examined the hestia configuration files for the control panel but the only client_max_body_size I’ve found is at:



client_max_body_size 1024m;

Yet downloading much larger 2gb .tar backups is NOT a problem via the control panel. What am I missing to get a user’s website to support > 1.08gb single file downloads?

Problem solved. The logs/ reveals that the upstream (Apache) connection was ‘prematurely closed’ on :8443. This tells us that it’s the apache2.ssl.conf file that needs help. I simply inserted:

ProxyTimeout 600
Timeout 600

within the VirtualHost block and that gives ample time for the download to complete. Problem resolved! :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.