[SOLVED] Wordpress permlinks not working after migration from VestaCP

On my server I have two vm’s (VestaCP and HestiaCP).

After migrating a couple of sites, i’ve changed the firewall rules to point to the new server, everything works except the permalinks from wordpress sites (main page works, any other page gives a 404)

All defaults.

How can I fix this, i’ve seen many google search results with the issue (quite old) but with no simple solution (adding custom templates ?)

thank you.

What is your current setup?

internet -> router -> proxmox.
Router redirects 80 and 443 to VestaCP in proxmox.

I migrated the websites from vestacp to hestiacp (separate vm on separate IP) and to switch I just change the firewall rule to point the destination IP for the new VM.

I’ve regenerated the SSL certificates, main webpage loads but nothing that has permlinks. I haven’t tried to regenerate them yet and I don’t have credentials to backend.

That is the first thing that I would do.

Apache2 or Nginx?

If Nginx select the wordpress template

I can’t find a wordpress hosting template in the front-end.

in webtemplates I have only the “default” template.

I’ve fixed the issue but why I can’t see other templatesc ? :slight_smile:

thank you - i’ve added a admin account via mysql and rebuild the permalinks, now it works.

If nginx is running in proxy mode you can still use .htaccess file. In standalone mode you are forced to use templates.

In @jlguerrero he is using Nginx + Apache2 and then templates are not needed…

Should I have more options here ?

1 Like

No. You are using apache + nginx as Proxy

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.