Some problems with 1.2.0 RC installation

[email protected]:~# dpkg -i hestia-nginx_1.17.10.deb
(Reading database … 112203 files and directories currently installed.)
Preparing to unpack hestia-nginx_1.17.10.deb …
Unpacking hestia-nginx (1.17.10) over (1.17.5) …
Setting up hestia-nginx (1.17.10) …
Processing triggers for systemd (237-3ubuntu10.41) …
Processing triggers for ureadahead (0.100.0-21) …
[email protected]:~# dpkg -i hestia-php_7.4.6.deb
(Reading database … 112203 files and directories currently installed.)
Preparing to unpack hestia-php_7.4.6.deb …
Unpacking hestia-php (7.4.6) over (7.3.11) …
dpkg: dependency problems prevent configuration of hestia-php:
hestia-php depends on libonig5 | libonig4; however:
Package libonig5 is not installed.
Package libonig4 is not installed.

dpkg: error processing package hestia-php (–install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
hestia-php
[email protected]:~#

I got the server running on digitalocean server and I build the server with ubuntu 20.04

[email protected]:~# apt-get install libzip5
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package libzip5 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘libzip5’ has no installation candidate

so i’ve installed libonig4 and it’s working fine now

[email protected]:~# dpkg -i hestia_1.2.0_amd64.deb
(Reading database … 111991 files and directories currently installed.)
Preparing to unpack hestia_1.2.0_amd64.deb …
Unpacking hestia (1.2.0) over (1.1.1) …
Setting up hestia (1.2.0) …

            _   _           _   _        ____ ____
           | | | | ___  ___| |_(_) __ _ / ___|  _ \
           | |_| |/ _ \/ __| __| |/ _` | |   | |_) |
           |  _  |  __/\__ \ |_| | (_| | |___|  __/
           |_| |_|\___||___/\__|_|\__,_|\____|_|

              Hestia Control Panel Software Update
                        Version: 1.2.0

========================================================================

(!) IMPORTANT INFORMATION:

Default configuration files and templates may be modified or replaced
during the upgrade process. You may restore these files from:

Backup directory: /root/hst_backups/230620201342/

This process may take a few minutes, please wait…

========================================================================

() Hardening Apache2 Server Status Module…
(
) Install sury.org Apache2 repository…
() Updating Roundcube configuration…
(
) Updating exim4 configuration…
() Configuring Filegator FileManager…
(
) Upgrading phpMyAdmin to version v5.0.2…
() Rebuilding domains and account for user: admin…
(
) Restarting services…
Error: ERROR: Restart of hestia failed.

after running systemctl status hestia.service

[email protected]:~# systemctl status hestia.service
● hestia.service - LSB: starts the hestia control panel
Loaded: loaded (/etc/init.d/hestia; generated)
Active: failed (Result: exit-code) since Tue 2020-06-23 13:43:07 UTC; 47s ago
Docs: man:systemd-sysv-generator(8)
Process: 17921 ExecStop=/etc/init.d/hestia stop (code=exited, status=0/SUCCESS)
Process: 18079 ExecStart=/etc/init.d/hestia start (code=exited, status=1/FAILURE)

Jun 23 13:43:07 lb.b2btech.in systemd[1]: Starting LSB: starts the hestia control panel…
Jun 23 13:43:07 lb.b2btech.in hestia[18079]: * Starting hestia-nginx hestia-nginx
Jun 23 13:43:07 lb.b2btech.in hestia[18079]: /usr/local/hestia/nginx/sbin/hestia-nginx: /lib/x86_64-linux-gnu/libcrypt.so.1: version XCRYPT_2.0' not found (required by /usr/local/hestia/nginx/sbin/hestia-nginx) Jun 23 13:43:07 lb.b2btech.in hestia[18079]: /usr/local/hestia/nginx/sbin/hestia-nginx: /lib/x86_64-linux-gnu/libc.so.6: version GLIBC_2.28’ not found (required by /usr/local/hestia/nginx/sbin/hestia-nginx)
Jun 23 13:43:07 lb.b2btech.in systemd[1]: hestia.service: Control process exited, code=exited status=1
Jun 23 13:43:07 lb.b2btech.in systemd[1]: hestia.service: Failed with result ‘exit-code’.
Jun 23 13:43:07 lb.b2btech.in systemd[1]: Failed to start LSB: starts the hestia control panel.

If you would follow the docs, you will see that this can be fixed with a apt-get install -f (and is also properly documentated :slight_smile:).

Probaly then there is something wrong with the image or digitalocean has some mixed repos - from the official focal repo you only should get libzip5 (https://packages.ubuntu.com/focal/libzip5), libzip4 is inexistent (https://packages.ubuntu.com/focal/libzip4).

Please fill out a proper issue report and add all informations you got, so we can tackle down the issue: https://github.com/hestiacp/hestiacp/issues/new

wget https://apt.hestiacp.com/beta/hestia_1.2.0_amd64.deb
wget https://apt.hestiacp.com/beta/hst-ubuntu-2004/hestia-nginx_1.17.10.deb
wget https://apt.hestiacp.com/beta/hst-ubuntu-2004/hestia-php_7.4.6.deb

dpkg -i hestia-nginx_1.17.10.deb
dpkg -i hestia-php_7.4.6.deb

apt-get update
apt-get install -f

dpkg -i hestia_1.2.0_amd64.deb

This is what steps i’ve followed and i’m still getting the same error

You downloaded the 20.04 ubuntu packages, do you already have a running hestia system on this version? The docs are for upgrading a existing hestia system, not for a fresh installation.

Yes i was running hestia 1.1.1 before

As I wrote, you downloaded ubuntu 20.04 packages, but hestia 1.1.1 doesnt support ubuntu 20.04. Without detailed informations what exact you have done and also about your system, we can’t help.

Best way currently to install directly 1.2.0 RC is to download

wget https://raw.githubusercontent.com/hestiacp/hestiacp/master/install/hst-install-ubuntu.sh

Then download the hestia_1.2.0_amd64.deb

wget https://apt.hestiacp.com/beta/hestia_1.2.0_amd64.deb

Run the installer

bash ./hst-install-ubuntu.sh --with-debs /path/to/debs_folder

When complete download both nginx and php deb and install those.

Or wait for about more week for the full release…

For upgrading to 1.2.0 / 20.04 from 18.04 / 1.1.1

  1. Upgrade Hestia to 1.2.0
  2. Update Ubuntu to 20.04

Check if iptables is still working if not replace search some where in the 20.04 testing topic for the correct change

Did this method with 1 server with minor issues (Iptables paths missing)

3 Likes

Hello, So i’ve installed a fresh ubuntu 20.04 and i followed the steps as you mentioned and now i’m getting this error

wget https://raw.githubusercontent.com/hestiacp/hestiacp/master/install/hst-install-ubuntu.sh
wget https://apt.hestiacp.com/beta/hestia_1.2.0_amd64.deb

bash ./hst-install-ubuntu.sh --with-debs /tmp/hestiacp-src/debs --apache yes --nginx yes --phpfpm no --multiphp yes --vsftpd no --proftpd yes --named yes --mysql yes --postgresql no --exim yes --dovecot yes --clamav no --spamassassin no --iptables no --fail2ban no --quota yes --api yes --lang en --hostname hostnamehere --email [email protected] --password passwordhere --force yes


| | | | ___ | |() __ _ / | _
| |
| |/ _ / __| __| |/ ` | | | |) |
| _ | _/_ \ |
| | (
| | |
| __/
|
| |
|_||/_||_,|__||

                  Hestia Control Panel
                                v1.2.0

====================================================================

The following server components will be installed on your system:

  • NGINX Web / Proxy Server
  • Apache Web Server (as backend)
  • Multi-PHP Environment
  • Bind DNS Server
  • Exim Mail Server
  • Dovecot POP3/IMAP Server
  • MariaDB Database Server
  • ProFTPD FTP Server

====================================================================

Would you like to continue with the installation? [Y/N]: y
Installation backup directory: /root/hst_install_backups/240620200028
Installation log file: /root/hst_install_backups/hst_install-240620200028.log

Adding required repositories to proceed with installation:

() NGINX
(
) PHP
() Apache2
(
) MariaDB
(*) Hestia Control Panel

Updating currently installed packages, please wait…|

Installation Aborted

Install script does not match Hestia release version
Please use the installer from the release branch

To test the beta version you need to build the hestia deb packages and re-run the installer
./hst_autocompile.sh --hestia no
./hst-install.sh … --with-debs /tmp/hestiacp-src/debs
Error: Installation aborted

--with-debs is pointing to a folder that contains the .deb packages?

Yes

ahh i forgot to put --with-debs /root/tmp/hestiacp-src/debs

Sorry about that!

1 Like

you are using the wrong dir

Installation works fine, ProFTPD Fail to start after reboot

Another issue i’ve notice is when i create backup and try to download the backup

it’s creating another backup request instead of downloading the backup file i’m getting this

1 Like

Also it’s bypassing the Package limit

for example in Package i’ve set the backup limit to 1 and it’s keep creating a new backup instead of deleting the old backup and creating new one

Will be fixed with this bug fix

After i click here

it’s still not working. it’s throwing this error now

Also it’s still bypassing the package limit which is set to 1