Sources problem upgrading from Debian 10 to 11

After changing “buster” to “bullseye” in /etc/apt/sources.list and /etc/apt/sources.list.d/* and doing an “apt update” I get the following errors:

Err:8 http://mirror.hetzner.de/debian/security bullseye/updates Release                                                                                                                             
  404  Not Found [IP: 213.133.99.97 80]
Hit:9 https://nginx.org/packages/mainline/debian bullseye InRelease                                                                                                                         
Hit:10 https://packages.sury.org/apache2 bullseye InRelease                                                                                                                                 
Ign:11 https://mirror.mva-n.net/mariadb/repo/10.4/debian bullseye InRelease                   
Err:12 https://mirror.mva-n.net/mariadb/repo/10.4/debian bullseye Release
  404  Not Found [IP: 195.65.111.42 443]
Hit:13 https://packages.sury.org/php bullseye InRelease
Hit:14 https://apt.hestiacp.com bullseye InRelease
Reading package lists... Done
E: The repository 'http://mirror.hetzner.de/debian/security bullseye/updates Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'https://mirror.mva-n.net/mariadb/repo/10.4/debian bullseye Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.```

Those are the contents of the sources.list, hetzner-security-updates.list and mariadb.list files:

deb http://deb.debian.org/debian bullseye main
deb-src http://deb.debian.org/debian bullseye main

deb http://deb.debian.org/debian-security bullseye-security main contrib
deb-src http://deb.debian.org/debian-security bullseye-security main contrib
deb http://deb.debian.org/debian bullseye-updates main
deb-src http://deb.debian.org/debian bullseye-updates main

# deb http://deb.debian.org/debian bullseye-backports main
# deb-src http://deb.debian.org/debian bullseye-backports main
deb http://mirror.hetzner.de/debian/security bullseye/updates main contrib non-free
deb [arch=amd64] https://mirror.mva-n.net/mariadb/repo/10.4/debian bullseye main

What am I doing wrong? Thank you.

MariaDB has no packages for Bullseye:

See:
https://mirror.mva-n.net/mariadb/repo/10.4/debian/dists/

So probally the best method is update your DB version

For Hetzner:

deb http://mirror.hetzner.de/debian/packages bullseye main contrib non-free
deb http://mirror.hetzner.de/debian/packages bullseye-updates main contrib non-free
deb http://mirror.hetzner.de/debian/packages bullseye-backports main contrib non-free

and

deb Index of /debian/security/ bullseye-security main contrib non-free

1 Like

The Hetzner issue is solved, thanks.What is the correct way to upgrade MariaDB before upgrading Debian?

Manualy upgrade first to 10.6, you’ll find a helper script here: hestiacp/upgrade_mariadb.sh at main · hestiacp/hestiacp · GitHub

Today I feel particularly awkward. Sorry for the inconvenience:

[email protected]:~# wget https://github.com/hestiacp/hestiacp/blob/main/install/upgrade/manual/upgrade_mariadb.sh
--2021-10-31 13:56:34--  https://github.com/hestiacp/hestiacp/blob/main/install/upgrade/manual/upgrade_mariadb.sh
Resolving github.com (github.com)... 140.82.121.3
Connecting to github.com (github.com)|140.82.121.3|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: ‘upgrade_mariadb.sh’

upgrade_mariadb.sh                                    [ <=>                                                                                                       ] 158.43K  --.-KB/s    in 0.01s   

2021-10-31 13:56:35 (12.4 MB/s) - ‘upgrade_mariadb.sh’ saved [162229]
[email protected]:~# chmod +x upgrade_mariadb.sh 
[email protected]:~# ./upgrade_mariadb.sh 
./upgrade_mariadb.sh: line 7: syntax error near unexpected token `newline'
./upgrade_mariadb.sh: line 7: `<!DOCTYPE html>'
[email protected]:~#

What can be happening?

Open the file, you downloaded the website. You need to load the raw file.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.