.sql.gz file import in phpmyadmin is not working

Dear Friends,

I am trying to import a mysql file to phpmyadmin on the page https://hcp.domain.com/phpmyadmin/index.php?route=/import

and the imported file is filename.sql.gz

Please help me on how to import this database file to phpmyadmin.

Thanks,

Hi @khaiser,

What’s the size of the sql.gz file? I suppose it is bigger than allowed size limit for your php version.

When you try to import the file using PhpMyAdmin you will see the max size allowed:

If that is the case, you should raise the size limits for post_max_size and upload_max_filesize directives.

Two options:

1.- The hard way :wink:

For example, if your default php version is 8.2, you should edit file /etc/php/8.2/fpm/php.ini and in that file search for post_max_size and upload_max_filesize directives and change the value for the one that fits your needs.

Example:

post_max_size = 50M
upload_max_filesize = 50M

Save the file and restart the service.

systemctl restart php8.2-fpm

2.- The easy way.

From Hestia Web UI, go to Server settings and there hover your mouse around your php service and once the pencil icons appears, click on it:

In the next screen modify the limits and click Save

And that’s all.

3 Likes

Thank you so much bro @sahsanu that solved my problem… :star_struck: you looks to me like an angel bro…

1 Like