SSH and FTP errors

hello, i installed the current version today.
now i have problems with my ssh because i always get mail with:
OpenSSH can not be restarted. Please check config:

and then I created a user, as far as everything goes well.
only I can not upload anything in you / public_html
the client says:
150 Ok to send data.
Answer: 426 Failure reading network stream.
Error: file transfer failed

this is a file index.php

Server log:
Sun Mar 29 13:12:29 2020 [pid 2296] CONNECT: Client “”
Sun Mar 29 13:12:29 2020 [pid 2295] [forum_release] OK LOGIN: Client “”
Sun Mar 29 13:12:41 2020 [pid 2300] CONNECT: Client “”
Sun Mar 29 13:12:42 2020 [pid 2299] [forum_release] OK LOGIN: Client “”
Sun Mar 29 13:12:44 2020 [pid 2301] [forum_release] FAIL UPLOAD: Client “”, “/public_html/new/test.php”$
Sun Mar 29 13:12:46 2020 [pid 2301] [forum_release] FAIL UPLOAD: Client “”, “/public_html/new/test.php”$
Sun Mar 29 13:12:48 2020 [pid 2301] [forum_release] FAIL UPLOAD: Client “”, “/public_html/new/test.php”$

Is there a solution to the problem?

hey sv3n,

seems like you are mixing two topics here. we looked into the first issue with the mail about “openssh can not be restarted” in anohter thread already. this is part of hestias function to check if sftp is correctly set up, which happens on reboot. for now that mail can be ignored, as that check simply happens to early on some fast systems. openssh gets started during boot independently, so you should not have to worry about accessing your system

for the second issue you sadly don’t tell, what kind of user you created and where. is it a new user created directly in Hestia, a system user created via shell command or an additional ftp user created under the web domain of another user?
how do you try to upload? winscp, any ftp client etc.?

1 Like

I solved the error with the ftp. it was because of my firewall.

if you say i can ignore that with ssh everything is fine.

or can you turn it off so that I don’t get an email?

1 Like

we are aware and I am sure it will be fixed in one of the next patches/releases.

if the mail really annoys you (should only happen on reboot anyway) and you feel up to it, you can have a look at /usr/local/hestia/bin/v-add-sys-sftp-jail and add a sleep 1 in line 50 as a workaround.

(if you are not sure, what that means, just don’t and simply ignore the mail for now ;-))

PS: glad you solved the other problem, ftp behind a firewall/nat needs to use passive mode, that’s most likely what happened here :wink:

1 Like