Ssh key - connection refused

SSH again. Sorry, but I’ve tried to read all I could find. I tried several times - created keys for admin by admin, by admin for user, by user for user. The public keys are accepted without a problem. Used putty, pageant. Ubuntu 20, first allowed ssh in the firewall, then disabled the firewall.

Nothing helps. All I get is “connection refused”. Is there anything else I can try?

User set to bash or sh? In Shell

Ssh. Can’t see bash in Putty or WinScp.

@eris means what is the shell that user has in HestiaCP.

In user options, in advanced options you will see option SSH Access:


Check: Edit user → Advanced

Probably it is still on “no login”


Yes, it’s bash there. Meanwhile, I’ve created different keys in Puttygen - SSH-1 (RAS) rather than RSA. And there was some progress - instead of “connecion refused” I got errors like “your key is not accepted”. But the main thing is that now I can login in with root (or user) and password like it was before Hestia installation. Which makes me very happy, no matter what.

SSH1 was retired many years ago. Such a key is unlikely to be useful.

Allowing root login by password is dangerous. It is considerably safer to login as a user and use sudo, even more so if you only allow public key authentication.

I don’t know how to obtain more verbose details in PuTTY, but you can use -v from the command line with OpenSSH. You can add more vs to increase verbosity. I expect that PuTTY would have a similar setting in its options. That is how you get the information to help you determine what is wrong.