SSH port other than 22 causes file manager error

The default ssh port is not 22, which will cause an error in the file manager! Please tell me how to fix this error, thank you for your answer!
The SSH port currently in use is 29875
This is the port specified by the hosting provider!
Please refer to the error!

Show the output of these commands:

v-list-firewall json | jq -r '.[] | select(.COMMENT=="SSH")'
v-list-sys-sshd-port plain

root@debian:~# v-list-firewall json | jq -r ‘. | select(.COMMENT==“SSH”)’
“PORT”: “29875”,
“IP”: “”,
“SUSPENDED”: “no”,
“TIME”: “17:14:41”,
“DATE”: “2014-09-16”

That’s ok, and the output of the second command?

Also, these two commands:

v-list-user admin json | jq -r '.[].SHELL'
grep -riE 'sftp|AllowUsers|Authentication|UsePAM|Port' /etc/ssh/sshd_config /etc/ssh/sshd_config.d/
root@debian:~# v-list-sys-sshd-port plain
root@debian:~# v-list-user admin json | jq -r '.[].SHELL'
root@debian:~# grep -riE 'sftp|AllowUsers|Authentication|UsePAM|Port' /etc/ssh/sshd_config /etc/ssh/sshd_config.d/
/etc/ssh/sshd_config:Port 29875
/etc/ssh/sshd_config:# Authentication:
/etc/ssh/sshd_config:#HostbasedAuthentication no
/etc/ssh/sshd_config:# HostbasedAuthentication
/etc/ssh/sshd_config:ChallengeResponseAuthentication no
/etc/ssh/sshd_config:#KerberosAuthentication no
/etc/ssh/sshd_config:#GSSAPIAuthentication no
/etc/ssh/sshd_config:# Set this to 'yes' to enable PAM authentication, account processing,
/etc/ssh/sshd_config:# and session processing. If this is enabled, PAM authentication will
/etc/ssh/sshd_config:# be allowed through the ChallengeResponseAuthentication and
/etc/ssh/sshd_config:# PAM authentication via ChallengeResponseAuthentication may bypass
/etc/ssh/sshd_config:# and ChallengeResponseAuthentication to 'no'.
/etc/ssh/sshd_config:UsePAM yes
/etc/ssh/sshd_config:GatewayPorts no
/etc/ssh/sshd_config:Subsystem sftp internal-sftp
/etc/ssh/sshd_config:PasswordAuthentication yes
/etc/ssh/sshd_config:PubkeyAuthentication no
/etc/ssh/sshd_config:# Hestia SFTP Chroot
/etc/ssh/sshd_config:Match User sftp_dummy99,admin,www
/etc/ssh/sshd_config:    ForceCommand internal-sftp

Edit /etc/ssh/sshd_config file and change

PubkeyAuthentication no


PubkeyAuthentication yes

Save the file and restart sshd:

systemctl restart sshd

And try again.

1 Like

Very perfect solution!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.