SSL cert for webmail.domain.com

When I enable ssl for mail domain it says:
To enable Let’s Encrypt SSL, ensure that DNS records exist for mail.mydomain.com and webmail.mydomain.com!
But when I try to open webmail.mydomain.com there is an error that ssl cert in invalid (it uses cert for mydomain.com without webmail alias).
And when I add alias to mydomain.com - www and webmail to receive correct ssl cert nginx redirects to empty page webmail, not to roundcube.
I have to manually copy ssl cert with webmail alias to other folder, delete webmail alias in WWW and add path to this ssl cert to webmail nginx settings.

Is there correct way to do this?

Do not add webmail.domain.com and mail.domain.com as an alias

Make sure in DNS both mail.domain.com and webmail.domain.com exits and then enable ssl

Thanks I will try this.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.