SSL Certificate issues

Please I need help
I have been using Hestia Control for about 6 months and I have not had any issues. Just yesterday all the SSL certificates on the hostname and all the subdomains I created on that domain are not working.
Am using Cloudflare for the DNS records. I have created the subdomains at Cloudflare. Example: the main domain is example.tld and hostname is panel.example.tld, I have also added subdomains like course.example.tld, and host.example.tld but all other user websites’ SSL certificate is working fine.
Everything was working fine, I don’t know why the SSL certificate stopped working yesterday. I have already tried this code:
but did not work. Please what can I do

You most likely need to adjust your Cloudflare configuration to prevent it from interfering with the Let’s Encrypt acme-challenge.

Here is one method.

The Let’s Debug website can be very useful in identifying where the Let’s Encrypt challenge is failing.

Thank you.
Please the result

I explain that result in the Cloudflare topic I linked earlier.

Have you made the Cloudflare adjustments to allow the ACME challenges reach your Hestia server?

Please I would like to know if I remove the domain from Cloudflare and I add all the records back to the domain registrar and remove the Cloudflare nameservers, can that solve the problem?

1 Like

Yes. If you remove cloud flare from the equation…

You can just pause Cloudflare and achieve the same result a lot quicker. You are better off to just add the relevant rule to your Cloudflare settings and tap reap the benefits of both.