SSL for admin panel

ssl

Chrome swings when I go to admin panel

NET::ERR_CERT_AUTHORITY_INVALID

Vesta had the same

/usr/local/hestia/ssl/
put to this directory your certificate.crt and certificate.key files
or edit existing files

Or use the command

https://docs.hestiacp.com/cli_commands/web_management_commands.html#v-add-letsencrypt-domain

/usr/local/hestia/bin/v-add-letsencrypt-domain admin domain

Checkout v-add-letsencrypt-host, it will do the complete job for younand create a let’s encrypt cert :).

There is no v-add-letsencrypt-host command here

When I install, does the panel do the same?

Should I put this team into putty? Can 't get a certificate through the interface?

Just run v-add-letsencrypt-host and be sure, you’ve set a valid hostname with proper dns record to your server and all will be done for you.

If the command isnt in doc, this doesnt mean it doesnt exist at all, this was added during 1.1.0 release and isnt yet in the docs.

1 Like

V-add-letsencrypt-host is a certificate for the panel interface domain, not for the user site?

Sorry for being boring, I 'm afraid of these certificates)

for the backend/interface, exim, dovecot and vsftpd.

you should neither be afraid of using cli commands nor handling ssl certificates at all. they don’t bite, and more importantly, if you don’t know (or want to learn) how it works, then sadly hestia is the wrong software for you :wink:
hestia will always have some things you need to do manually still, because if that’s just part of the initial setup usually everyone is fine with it…

1 Like

[email protected]:~# v-add-letsencrypt-host
Error: Web domain site.ru exist
Error: web domain site.ru doesn’t exist

It is ok?


I deleted the domain admin user, I added it to the new user

How about no? xD

Probaly you set site.ru as hostname and used it ubder a normal user as webdomain? You need to set a propper hostname like server.domain.tld. But this are knowledge basics, we arent here for teaching them.

When the Hestia was installed, it had received a certificate for the main domain. Screenshot in the first message confirms this - it is exactly the time when the panel was installed.

I deleted the domain from admin user - I deleted the domain for “users’s site” not for “admin panel”.
A certificate exists in the “Server” properties. But why then there is a mistake NET::ERR_CERT_AUTHORITY_INVALID ?

You mean I have to make a separate sub-domain like admin.site.ru for the admin-panel and get a certificate for it again?

I’m sorry but I have to stop here with the support, I can’t guide you how to setup the whole server - we’re just not here for this as I already pointed you to this thread here: Please read this, before you start!

This should not be offensive at all, we just havent enough time to teach everyone how to setup their server and get basic knowledge, there are other ressources to gain it.

Everything is normal. I am without claims)

“v-add-letsencrypt-host” worked like a charm.
Earlier I had enabled lets-encrypt on one of my servers manually.
Thanks so much.

1 Like