SSL for HestiaCP panel

I write v-add-letsencrypt-host and get

root@panel:~# v-add-letsencrypt-host
Error: Let’s Encrypt validation status 400 ( Details: 403:“IP HERE: Invalid response from*************************************************: 404”
Error: Let’s Encrypt SSL creation failed
I don’t use CloudFlare.
I installed the panel now, how can I fix it?

It should be good to know what is the actual server name to test it from our side.

Okay, no problem
Error: Let’s Encrypt validation status 400 ( Details: 403:“ Invalid response from*************************************************: 404”

Please, show the output of these commands:

hostnamectl hostname
hostname -f
v-search-object panel
root@panel:~# hostnamectl hostname
Unknown operation hostname.
root@panel:~# hostnamectl
Unknown operation

root@panel:~# hostname -f

root@panel:~# v-search-object panel
USER     TYPE  KEY     RESULT                 ALIAS
admin    web   DOMAIN

What OS and version are you using?

Show the output of these commands:

ls -la /home/admin/conf/web/
grep 'include' /home/admin/conf/web/
grep -A3 'well-known' /home/admin/conf/web/
cat /home/admin/conf/web/

System: Ubuntu 20.04.6

ls -la /home/admin/conf/web/

root@panel:~# ls -la /home/admin/conf/web/
total 16
drwxr-xr-x 2 root root  4096 Nov 18 02:42 .
drwxr-x--x 3 root root  4096 Nov 17 02:37 ..
-rw-r----- 1 root admin    0 Nov 18 02:42 apache2.conf
-rw-r----- 1 root admin    0 Nov 18 02:42 nginx.conf
-rw-r--r-- 1 root root   159 Nov 20 06:50 nginx.conf_letsencrypt
lrwxrwxrwx 1 root root    65 Nov 17 02:38 nginx.ssl.conf_letsencrypt -> /home/admin/conf/web/

No information:
grep ‘include’ /home/admin/conf/web/

root@panel:~# grep 'include' /home/admin/conf/web/

No information:
grep -A3 ‘well-known’ /home/admin/conf/web/

root@panel:~# grep -A3 'well-known' /home/admin/conf/web/

cat /home/admin/conf/web/

root@panel:~# cat /home/admin/conf/web/
location ~ "^/\.well-known/acme-challenge/([-_A-Za-z0-9]+)$" {
    default_type text/plain;
    return 200 "SECRET INFO?";

I’m wondering why those conf files are empty, you are not using any conf, neither for nginx nor apache.

Try to rebuild the web domain:

v-rebuild-web-domain admin

Once done, check again that you have the right conf:

grep ‘include’ /home/admin/conf/web/
grep -A3 ‘well-known’ /home/admin/conf/web/

Both commands should show info.

If you see info from above commands, test whether you are serving the well-known info correctly:

Open your browser and navigate to this url:

If all is working, you should see a line like test.here_your_long_alpha_numeric_string

If it still doesn’t work, restart nginx and try again.

systemctl restart nginx

If it works, try again to issue a Let’s Encrypt certificate.


Thanks a lot. Problem solved.
Is it okay that anyone can see this on the site?: 1

The best thing to do is to delete the topic, please, so that no data remains. Thanks again!

You are welcome. I’m glad you issued the certificate for your domain.

Yes, it is ok. Keep in mind that in this case, test is the token and nobody knows what the real token is. As I said, no problem.

I don’t like to delete topics so I’m going to edit all the posts on this topic to replace your actual domain with


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.