SSL for mails doesn't work


I restored a Hestia backup on a new Debian 10 server but since then I have not been able to activate SSL for webmail.

When I check the box in the mail domain option, it says “Changes have been saved.” but nothing happens, no error message.

I checked well:

  1. I have an A record for mail and webmail which points to my IP in the panel and at my registar.
  2. SSL does work for my main domain.

Could you please help me?

Thank you!

Strangely enough, I managed to get it working. Here is how:

  1. Check the box Enable SSL for this domain but uncheck the box Use Lets Encrypt to obtain SSL certificate.

  2. Go back to the settings, now check both boxes.

It worked for me… Maybe this is due to the backup restore, it had to “reset” something.

1 Like

We might need to investigate it… Thanks for reporting

This is happening to me.
Same server and IP, also have records in DNS but will not add SSL to mail.
I had to reinstall panel because it needed new hard drive.Tried cyclone200 fix, but not working here.
Going to reinstall to see if I missed anything.

Please open another thread, it doesnt sound like this is the same issue.

This is the error I get, it seems the same.
Error: DNS record for doesn’t exist
I’ll reinstall and make a new thread if I still have problems.

Please show me where he wrote that error ;). Create an a record for webmail.domain.tld and it should work.

I have records for webmail and also one for mail in the panel.
When I saw “I have an A record for mail and webmail which points to my IP in the panel”
I thought I might have the same error.

Verify if your server gives a reply to nslookup webmail.domain.tld

1 Like

Just a note, it might help: Yesterday, I had two backups to restore on two different fresh Debian 10 VPS. My fix worked both times.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.