Strange Problem with DNS Cluster

I am practicing creating a DNS cluster, and I thought it was working fine until now.

I have this structure:

  • HestiaCP server with “clients 1” accounts
  • HestiaCP server with “clients 2” accounts
  • HestiaCP server with “clients 3” accounts
  • Hestia server, DNS 1 - dns1.clusterhestia.com
  • Hestia server, DNS 2 - dns2.clusterhestia.com

HestiaCP servers with client accounts have been configured as Master according to the documentation, and the two Hestia DNS servers as slaves.

Is this structure correct, or am I making a mess?

Here’s the situation:

On the master “clients 1,” I run: v-sync-dns-cluster

Both DNS servers show all domains with:

v-list-dns-domains sincdns

I test the domain at: intoDNS: - check DNS server and mail server health, and both DNS servers respond correctly.

After a few minutes, I run tests again, and the DNS server 2 does not respond, and the command v-list-dns-domains sincdns shows no results.

How is it possible that it gets removed from server 2? I must be missing some step.

Regards!

Yeah i had this issue as well, it would randomly delete the entries after a while. The solution is to use the new method.

the one where it ask you add this ;

# Change this line
allow-recursion { 127.0.0.1; ::1; };
# To this
allow-recursion { 127.0.0.1; ::1; your.master.ip.address; };
# Add this line
allow-notify{ your.master.ip.address; };

Above is not the full instructions. You can see it in their documentation. Also use the secret key method.

I use that method, I added both with the API key, yet it keeps getting deleted, I have added the values in the configuration files, etc… that’s why I wrote here, I didn’t know what else to look at haha

Now something even stranger is happening, before there were 12 results, I run the command again and it only shows one domain… Any idea what I can look at to see what’s happening?

By the way, it only happens on server 2 of the cluster, I have deleted it again using: v-delete-remote-dns-host … I have added it again, same result, although now it has not deleted all of them, there is one result showing with the command: v-list-dns-domains sincdns

Make sure to use for each server an unique account on the DNS cluster server…

It seems that simply changing the account to sindns2 has worked. In cluster 1 I use sindns.

Thanks!!

1 Like