Stuck at "Installing dependencies"

When i am trying to install hestia it gets stuck on “Installing dependencies”.
I tried it on Ubuntu 22.04 and Debian 12 same result.
I tried also apt-get upgrade before.
I am using a Server from a Russian provider, called reg.ru
I noticed when i did an update that it takes some russian repos, can that be a reason?
I can give access to the server if someone whats to make a more detailed analysis.

Check the install log that you should have here:
/root/hst_install_backups/hst_install-HereANumber.log

Note: HereANumber would be the day, month, year, hour and minute when you tried the installation.

If the default system language is Russian, you could try this:

LANG=C bash hst-install.sh HereTheOptions

or this:

LANG=C LANGUAGE=C bash hst-install.sh HereTheOptions
1 Like

This is the last error I got:
client_loop: send disconnect: Broken pipe

It says there is no such file directory.
And when i try to “sudo cd root” it just jumps back where i am, or basically does nothing.
I guess the system is english, i hope at least.
When i fire those 2 last comands for default system language.
It says the same that there is no such file directory. oO

Hmm maybe it is because it seems i have min versions of ubunutu?
This system has been minimized by removing packages and content that are
not required on a system that users do not log into.

edit:
Ok i tried also 20.04 LTC and same problems, and it was not min version i guess.

But that is because your ssh connection dropped for some reason.

What you execute and where?

Execute the command locale to view what is the language in use.

But are you executing them as root and inside the directory where you downloaded the Hestia installer (hst-install.sh)?

1 Like

Hmm it is english.
Here the login, the message is one time readable.
https://cryptgeon.org/note/5I637A68815F7Z6h4W5s627X6D7P8C5j757Z7o896b6n5j7b5f6f6E4p5z5x5W5J#e8bd326c039cd9623dca6e24890137317095c79405cda8278f7abb3f063d6c55

I’ve logged in and started the installation without issues:

                _   _           _   _        ____ ____                  
               | | | | ___  ___| |_(_) __ _ / ___|  _ \                 
               | |_| |/ _ \/ __| __| |/ _` | |   | |_) |                
               |  _  |  __/\__ \ |_| | (_| | |___|  __/                 
               |_| |_|\___||___/\__|_|\__,_|\____|_|                    
                                                                        
                          Hestia Control Panel                          
                                  1.8.11                        
                            www.hestiacp.com                            

========================================================================

Thank you for downloading Hestia Control Panel! In a few moments,
we will begin installing the following components on your server:

   - NGINX Web / Proxy Server
   - Apache Web Server (as backend)
   - PHP-FPM Application Server
   - Bind DNS Server
   - Exim Mail Server + SpamAssassin
   - Dovecot POP3/IMAP Server
   - MySQL8 Database Server
   - Vsftpd FTP Server
   - Firewall (iptables) + Fail2Ban Access Monitor

========================================================================


Would you like to continue with the installation? [Y/N]: 

I’ve said N so you can start the installation yourself. I’ve removed ufw package.

You must use below command and remember to enclose the password between single quotes:

bash hst-install.sh --port HereThePort --password 'HereThePassword' --mysql8 yes

Said that, don’t use Ubuntu 20.04, use Ubuntu 22.04 or Debian 12.

1 Like

Hahaha ok strange but without the ‘’ you get the same beahaivor like me?
Ok, strange i just copied it from here Install | Hestia Control Panel
So maybe it should be implemented in the generator :stuck_out_tongue:
Yeah i was just testing 20.04 because i was suspicious about the distros :stuck_out_tongue:
OK i try my self lets see xDDD

1 Like

Ok lol those ‘’ really made the trick, and i kinda think to remember that i encountered these before.
One should really change to automatically add ‘’ those to the password at Install | Hestia Control Panel
Thank you endless much! Stuck with this for 3 days now already :stuck_out_tongue:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.