Subdomain does not open the domain site

I wanted to add a sub-domain to an existing site. But it opens not the site itself, but some “default” site… Which says “Success! Your new web server is ready to use.”

Once when saving the domain settings - when I added alias - I had error code 3, but externally everything was preserved.

How do I separate a domain from a “default” site to earn its “native” site?

Adding subdomain as a new domain should work for you, you’ll have to place the files in /home/user/web/

I don 't want a separate sub-domain) I need the primary domain to open. To make the sub-domain work like an alias.


but open separate site - not

You want to add an alias to a existing domain, which redirects automatically to the existing domain? If yes, add it to the alias field and create a htaccess rewrite rule. should open the same site as, there is no known issue that aliases arent working.

At me so) perhaps, it was worth prescribing alias before the first appeal to the subdomain. The system may have created this domain somewhere else. But i don 't know where it is

And what does the error # 3 while maintaining the configuration of the site - is the reason for this?

On my previous server I generally do not register anywhere - on any domain, aiming at my ip opened my website - it was convenient) And now I clearly prescribed a subdomain - and it doesn’t want to work))

Error Code 3 means Unknown Domain
Adding as an alias in works fine I’ve just tested now (with Cloudflare).

1 Like


And somewhere there is a log of request to unknown domains? Can my domain there

I can give access to the server to someone from the admins to check)

Do not understand what you mean, language barrier is rising :slight_smile:.

in left window i want to see “main site” :wink: not green “Success”

And i want to find - where requests to the sub-domain “super” go

Restart nginx helped! It must probably be done automatically?

Curious after all - where the request to the unknown domain went - where this green Success site?

Any http requests for undefined domains or subdomains that end up on your server will get that default “Succes” page which is located at /var/www/html/

When editing web domains the apache and or nginx services are restarted automatically, if that didn’t happened in your case it could be a Bug, to confirm that on our side we would need the steps to reproduce the problem.

Also you could check if /varlog/hestia/system.log contains entries for v-restart-service after editing a domain.

1 Like
/var/log/hestia/system.log                                                                                   5602194/5699K              95%
2020-06-09 23:35:04 v-restart-service  'nginx'

I only have one record of a restart this month… time - about a couple of hours later, as I edited the domain and created this topic - apparently, this is a manual restart.

nginx was not restarted when I edited the domain

it is unusual for me that in general it is necessary to prescribe some aliases… on my previous server on Vesta, all domains point to the one site - no aliases

Is there a default site for unknown domains? for example, I want all unknown domains to open - it will be convenient for me.
not that /var/www/html/ , but that /home/mysite/web/

I found this file:

/etc/nginx/conf.d/ 1089/1097 99%
server {
listen default;
server_name _;
location / {
access_log /dev/null;
error_log /dev/null;
root /var/www/html;

I do not want to set the site parameters into this file… it’s somehow not elegant. Or should it be replaced, and then the first domain will accept all requests for itself?

just add a html meta refresh in that /var/www/html/index.html file

I can’t waste a redirector. It is critical for me to immediately respond to the browser

No meta or 301-302 codes

From the point of view of hestia, I have one site - it has different “sites” of users. Users add their domains, I write them to the database. And everything works (on the old server). I am not comfortable writing every domain in the nginx configuration of the site

server {
listen 80;
server_name *;


How ever guarantee till the door and you need to have wildcard ssl certificate to support ssl

Oh. it was necessary to create a separate topic, because this is another question… If an option worked

server_name *;

indicated alias asterisk and received a fence from all unknown domains of the host - this would be an ideal solution)

question not about subdomains - but about all unknown domains

I don’t think it’s a good idea to modify the conf file itself, they will be rebuild on every hestia upgrade. So if you want to add them to your website, use the alias field in hestia interface when you edit the domain.

You can also work there with *.domain.tld.

You can modify your templates of Nginx / Apache how you want…

server_name %domain_idn% *.%domain_idn%;

Will probably work how. How ever I am not brother to test it currently working working on other projects…


1 Like


Added domains with his hands to alias - again error No. 3

It doesn’t want to save it. I have to restart the nginx with my hands

Do not have any such issues and can’t reproduce it. Is there something special with your domains?