Two errors during Hestia 1.4.3 Installation

Today I installed Hestia 1.4.3 on a Debian 10 VPS. I used the two default commands on the Hestia CP home page (as I have done dozens of times before without problem). I preceded these commands with

apt-get update && apt-get install ca-certificates

The first install attempt failed with the error:

Updating currently installed packages, please wait… W: GPG error: buster InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY A189E93654F0B0E5

E: The repository ‘ buster InRelease’ is not signed.

I solved this problem by reinstalling Debian 10 on the VPS and then adding the following commands after updating and before the two Hestia commands:

To update the Hestia SSH Keys:

apt-get install gnupg2


wget -qO - | sudo apt-key add -

The terminal replied with OK.

The installation was then able to proceed. However, near the end of the installation, Hestia gave this warning:

Configuring system settings…

[ * ] Configuring Hestia Control Panel…

[ * ] Generating default self-signed SSL certificate…

req: No value provided for Subject Attribute emailAddress, skipped

[ * ] Adding SSL certificate to Hestia Control Panel…

I am certain that I had properly added the email address. And I have installed Hestia many times in the past without this error. So I think there is a problem with Hestia 1.4.3.

The failure to find my email address prevented the installer from installing a Lets Encrypt Certificate. However, after the install, I was able to log into Hestia and add an SSL certificate to my primary domain address

Thus, all ended well. But I am hoping the leaders of Hestia can take a look at these two issues and find a fix for them for future versions of Hestia CP.

Thanks again for making such a terrific control panel!

req: No value provided for Subject Attribute emailAddress, skipped

It is not “required” to provide an email address (Except for Ubuntu 18.04) only result is that it “provide” a small warning.

Changes has been made due to the fact with an self signed certificate + email adress. “Hackers” where able to find a lot of Hestia servers… And potentially a security risk…

Lets Encrypt is generated on the first reboot of the system. I have tried it many times and as long the server hostname and DNS are setup propperly I didn’t had an issue.

Thank you for the clarification on the email issue. I have simply never seen that comment before during a Hestia installation.
As for the other issue, was the Hestia key really in need of updating or did I do something wrong?

openssl is strange about but the warning can be ignored…