"Unable to connect" error after manual update

Tried to install a drupal distro that required php 8.2 and I hurried to manually update to 1.7. Not being such a tech advanced person it’s a major plus for Hestia that it works even for me. :slight_smile:

First, the update stalled somewhere in the middle. After a few tries worked, the admin was working, but Nginx would’t start, with the error

49984#49984: bind() to websiteip:80 failed (98: Address already in use)
2023/03/22 15:24:56 [emerg] 49984#49984: still could not bind()

Then googling I found this commands in a forum thread,

sudo pkill -f nginx & wait $!
sudo systemctl start nginx

Now I have a working Nginx but the admin panel is working no more, with An error occurred during a connection to websiteip:8083

And I don’t know what did go wrong. Thank you for any help and I promise I won’t do it again.

It works the same for Nginx? I have Hestia installed with Nginx only.


lsof -I :80

That’s the output

nginx   52809     root   20u  IPv4 100003      0t0  TCP chum.mydomain.com:http (LISTEN)
nginx   52810 www-data   20u  IPv4 100003      0t0  TCP chum.mydomain.com:http (LISTEN)
nginx   52810 www-data   27u  IPv4 279596      0t0  TCP chum.mydomain.com:http->6.bl.bot.semrush.com:12456 (ESTABLISHED)

chum being the subdomainI assigned hestiacp after installation. That I accidentally deleted today. But, though, I don’t remember if it ever worked to open the CP via the url, only with the Ip.

So only Nginx should be fine

The last lines from Hestia error log are these

2023-03-22 15:18:19 v-restore-user  'admin' 'admin.2023-03-22_05-11-42.tar' [Error 12]
2023-03-22 15:23:44 v-restart-service  'nginx' '' [Error 20]
2023-03-22 15:23:47 v-restart-web  [Error 20]
2023-03-22 15:24:24 v-restart-service  'nginx' '' [Error 20]
2023-03-22 15:24:27 v-restart-web  '' [Error 20]
2023-03-22 15:24:27 v-add-web-domain-ssl-force  'admin' 'mydomain.com' [Error 20]
2023-03-22 15:24:56 v-restart-service  'nginx' '' [Error 20]
2023-03-22 15:24:59 v-restart-web  [Error 20]

Being able to download a backup prior to the crash but I could’t install it either as in the documentation. I got the error chum.mydomain.com belongs to another user