Unable to enable JIT compiler?

Hi
I am using PHP 8.2 and trying to turn on Jit compiler by adding the code below to php.ini at /etc/php/8.2/fpm/php.ini

opcache.enable_cli=1
opcache.jit_buffer_size=256M

Then I restarted php 8.2 by command: sudo service php8.2-fpm restart

But when I checked in the phpinfo file. The JIT is in disabled status.

What should I do?

Thanks

Hi @webmasteroffers,

Edit this file /etc/php/8.2/mods-available/opcache.ini

and replace

opcache.jit=off

by

opcache.jit=on

Save the file and restart php 8.2.

systemctl restart php8.2-fpm
3 Likes

It works perfectly, but I don’t see any acceleration. and you? opcache itself works well, but I don’t see any added value here?

Please check this post Exploring the New PHP JIT Compiler | Zend by Perforce
Base on their test, enable JIT will increase the speed of WP from 3%-5%

I tested as much as I could on 15 domains, various WordPress and WooCommerce websites. I haven’t noticed any positive effects.

The PHP JIT (Just-In-Time) Compiler, introduced in PHP 8, brings significant benefits to numerical processing performance, but only marginally improves the speed of typical PHP applications such as WordPress. JIT allows for direct execution of machine code, which can speed up some operations. However, for WordPress sites, the benefits are limited and may not justify the additional complexity and potential compatibility issues. Therefore, enabling JIT for WordPress is not necessary unless there are specific computing needs.

Yes, 3-5% is very small, so we usually don’t see any difference.

You can install the plugin atec Cache Info to see how many KB that JIT uses. For my websites. It is used from 1kb to 250kb depending on the kind of website.

ok thnx :slight_smile: