Update 1.1.1 broke server

Hey! I’m not an expert on servers and those thing but looks like the latest update (1.1.1 26 of March) broke something in my server and i’m getting error 500 in every PHP file, where I can check Hestia or php error log to check what’s happening or how do I restore to the version 1.1.0?

EDIT: can not even use php_info and it happens in every php file

Hi @tnt

The last update had no changes to the php or any other configuration, there were just a few minor adjustments and a security fix, which was the reason we shipped it faster than usual.

A hestia upgrade also does a rebuild of the web configuration files, like it happened already for 1.1.0. There is no way to downgrade, also I don’t think this would help to solve your issue.

You need to check your log files to see what exactly causes this issue, probaly something with php-fpm is wrong. Please add as much informations as possible, like your os, the way you installed hestia (nginx, apache2, multiphp…) and also probaly important parts out of your log files. This will help us, to help you :smiley:.

I just found error log of one of my domains:
[Fri Mar 27 15:54:13.597842 2020] [proxy:error] [pid 5577] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /run/php/php7.3-fpm-r.domain.com.sock (*) failed
[Fri Mar 27 15:54:13.597921 2020] [proxy_fcgi:error] [pid 5577] [client] AH01079: failed to make connection to backend: httpd-UDS

(I changed my domain name to domain.com for privacy)
Most part of the file is full of this error.
I’m using Debian 9.12, installed Hestia a few days ago and no problems until today, I installed Hestia using the homepage commands (step 3 & 4) so it might be apache, nginx and php-fpm (php 7.3).

Can you get the status of your php7.3-fpm service? Looks like the socket isnt running.

systemctl status php7.3-fpm

This is what I get:

php7.3-fpm.service - The PHP 7.3 FastCGI Process Manager
Loaded: loaded (/lib/systemd/system/php7.3-fpm.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2020-03-27 14:21:22 CET; 2h 20min ago
Docs: man:php-fpm7.3(8)
Main PID: 904 (php-fpm7.3)
Status: “Processes active: 0, idle: 0, Requests: 0, slow: 0, Traffic: 0req/sec”
Tasks: 1 (limit: 4915)
CGroup: /system.slice/php7.3-fpm.service
└─904 php-fpm: master process (/etc/php/7.3/fpm/php-fpm.conf)

Mar 27 14:21:20 srv.domain.com systemd[1]: Starting The PHP 7.3 FastCGI Process Manager…
Mar 27 14:21:22 srv.domain.com systemd[1]: Started The PHP 7.3 FastCGI Process Manager.
Mar 27 15:49:31 srv.domain.com systemd[1]: Reloading The PHP 7.3 FastCGI Process Manager.
lines 1-13

I don’t know if this can fix, but i’m trying to install php7.4

this sounds not like a good idea, this will break your server. Hestia shipped with 1.1.0 a modular php management, if you want to have 7.4, checkout the web config part in hestia backend under server.

I installed via Hestia Settings.

Okay I fixed the problem, i don’t know how to be honest but I selected as Backend Template PHP7,4 and this fixed 500 error. Anyways, thanks for your help!

1 Like

2 posts were split to a new topic: 500 internal server error after reboot